How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Dodge
Satisfied Customers: 35289
Experience:  ASE Certs
7276279
Type Your Dodge Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 2004 Dodge Durango SLT 5.7 AWD. Abput a month ago

Customer Question

Hi, I have a 2004 Dodge Durango SLT 5.7 AWD.
Abput a month ago the check engine light came on and and my scanner said it was a misfire in cylinder 7. I had a mechanic take a look and he used his scanner and it was showing a live reading and he said that it was showing that all cylinders were misfiring.
I was driving the truck for a month with no issues.
One night i filled up the tank and added 1 bottle of Lucas octane booster, only to read the label after I filled up that it said "for off road use only".
The following day the truck engine started to stutter and run very rough. When the light turned green I accelerated to the nearest parking spot.
The acceleration was slow and there was a huge loss of power. When I got into the parking spot, the engine was stuttering very badly and shut off.
Ive tried starting it a couple of times since then and it will run for a few seconds while stuttering and shaking only to shut off again.
What are some issues that I can be dealing with?
Submitted: 8 months ago.
Category: Dodge
Expert:  Ron replied 8 months ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 8 months ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here. Adding the octane booster should not have cause the problem you are having. Can you start with scanning the computer system and see what the fault code and or codes are that should be setting and post back with them and I will see if I can help you with this problem.

Customer: replied 8 months ago.
Hi Ron. I will scan it in the morning and get back to you.
Expert:  Ron replied 8 months ago.

Sure thing, post back when you ready and I will see if I can help you with this.