How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 21591
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I need help putting the arm on my Dodge dakota e yeah it

Customer Question

I need help putting the arm on my Dodge dakota e yeah it seems loose when I put it on what is a good repair for it
JA: What year is your Dakota?
Customer: 1990
JA: Are you fixing your Dakota yourself? What have you tried so far?
Customer: I am fixing it myself I am a woman I change the leakage the little white plastic thing I fix that now when I try to put the wiper arms back it seems like they're loose I like to know if there's a fix for that
JA: Have you checked the fuses? Do you know if there is power to the wiper motor?
Customer: Yes I checked all that everything is good when I turn the wipers on without the wipers it runs real good but I just can put the arms back on
JA: Anything else you want the mechanic to know before I connect you?
Customer: No that said I would like to know how to put those what those arms back on is killing me
Submitted: 3 months ago.
Category: Dodge
Expert:  sprinkles08 replied 3 months ago.

Hello and welcome to JustAnswer!

Without knowing exactly what issue you're having it's tough to say what needs to be done differently to install the arms. These arms are of conventional type of the era where the arm was raised slightly, the lock tab was slid over and then the arms pulled off. Installation simply requires pushing them back on and pushing the lock tabs back in.

What problem are you having specifically?

Customer: replied 3 months ago.
The arm is loose when I put the arm on the post the post move but the wipers don't
Expert:  sprinkles08 replied 3 months ago.

It sounds like the pivot arm or wiper arm is stripped then. If the pivot arm moves with the wiper motor runs, the arm is being installed properly yet the wiper arm doesn't move then the splines on either the pivot arm or wiper arm, or both, have to be stripped.