How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Dodge Technician
Category: Dodge
Satisfied Customers: 25062
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Dodge Question Here...
Amedee is online now
A new question is answered every 9 seconds

I have the same problem with no power to the fuel pump. In a

Customer Question

I have the same problem with no power to the fuel pump. In a post five years ago. You referenced connector 10 pin 18. My TIPM is letter labeled and color coated additionally. Also, i do not see any pin numbers located on the plastic connector. Can you tell me where I should look on my TIPM for the fuel pump supply power and ground?
JA: Is the power loss consistent, or does it fluctuate?
Customer: Consistent. Engine cranks no start. Installed new Crank and cam position sensors originally. Have spark but no fuel pressure at rail. Installed new fuel pump but when turn ignition on no fuel at discharge. Sending unit working fine. 2006 Dodge 5.7L Ram
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes, I will try to fix myself. I just mentioned what I have done so far.
JA: Anything else you think the mechanic should know?
Customer: Have one code: 0443. Replaced purge valve with no new results.
Submitted: 5 months ago.
Category: Dodge
Expert:  Amedee replied 5 months ago.

Hello and welcome! My name isCustomerand I can assist you with your question. I take it the engine does not start and run? Would you like a wiring diagram of the fuel pump circuit?

Expert:  Amedee replied 5 months ago.

Here is a connector view

Customer: replied 5 months ago.
I just checked for power to fuel pump from pin 18 connector ten; I have power from that pin(red/orange). Does this eliminate any issue with the TIPM? I have power to the new fuel pump. The sending unit is operating and the fuel pump comes on for a second or two. I crank the engine but no start. Are there any other sensors or devices that control the fuel pump run time?
Expert:  Amedee replied 5 months ago.

The cam and crank sensor could be the culprit

Expert:  Amedee replied 5 months ago.

But if they have been replaced I would check the computer and ASD operation while cranking.

Expert:  Amedee replied 5 months ago.

Hello! It'sCustomerfrom just answer.

I am just checking in to see if you need any further assistance?

Let me know!

Expert:  Amedee replied 5 months ago.

Hello! It'sCustomerfrom just answer.

I am just checking in to see if you need any further assistance?

Let me know!