How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 6712
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

I have a 2012 Chrysler 300 2.4L. I am a mechanic and my

Customer Question

I have a 2012 Chrysler 300 2.4L. I am a mechanic and my computer where I have my Schematics crashed. All I know is that the car get stolen and recovered. We get another key reprogram and the red dot is OK now (Meaning it was properly programmed) I am not getting pulses on the Injectors and spark plugs. I need help troubleshooting this car.Thanks
Submitted: 1 month ago.
Category: Dodge
Expert:  -Brad- replied 1 month ago.

Welcome to JustAnswer!!! My name is*****'m a 19 Yr Dodge dealership technician and I will be helping you with your question today...

Expert:  -Brad- replied 1 month ago.

What active codes are setting? Is the red light off?

Customer: replied 1 month ago.
No codes on the pcm. Red light is off. Sorry for the slow response I was away from the shop today. Thanks
Customer: replied 1 month ago.
Please let me know what I have to check Im at the shop now
Customer: replied 1 month ago.
Ey. Quick update.
At the injectors. The two wires are showing positive signal when the car cranks, there two wires, one close to the red clip (left wire) and the other one (right wire). When I put ground on the right wite car tries to start, it doesn't start cause I dont have a way to put ground on all four at the same time.
I don not have the diagrams for this car, but if you can tell me where I get the fround that is missing here I think I can get rid of this problem.A quick response will be appreciated
Expert:  -Brad- replied 1 month ago.

Good morning and sorry for the delay..

Your injectors operate off a 12v constant and a ground pulse from PCM. You can't have two 12v wires going to the injectors. If you ground the 12v ASD Feed then you will damage the PCM. What codes are being set?

Customer: replied 1 month ago.
No codes so far.
Both wires are 12v pulses. I would have to check wich is supposed to be the ground and track the problem. I do not have diagrams for this vehicle so I do not know
Expert:  -Brad- replied 1 month ago.
Can I get your VIN to grab a wiring diagram?
Customer: replied 1 month ago.
See attached picture
Expert:  -Brad- replied 1 month ago.

I attached the wiring diagram.. The Brown/Yellow on all 4 is the 12v constant ASD feed, and the other wire is a ground pulse from the PCM.. If the ground pulse has 12v then ohm it to the PCM if good wire replace PCM..

If you need anymore assistance feel free to reply and don't forget the RATING before leaving the site!!

Have a great day,


Expert:  -Brad- replied 1 month ago.

Do you need more help?

Customer: replied 1 month ago.
I am in a state emission training today and tomorrow. Can I leave this open? Dont wory about the rating, i know you from before and have no doubt your service is great. Please allow me to work on the diagram when I get back to the vehicle.Thanks
Expert:  -Brad- replied 1 month ago.


Customer: replied 1 month ago.
Ey Men I am back from my EPA test. I am going to start working on it. I will let you know
Customer: replied 1 month ago.
Ok. So I am getting ground pulses as it is supposed on every injector and Positive fron the ASD as it is sipposed to too. I disconnected the ignition coil electical connection and I am getting power in one wire and no signal on the other wire. Can I get a diagram for the coils?
Customer: replied 1 month ago.
Ey men. Are you still there? I measured continuity from the coil wire to the computer and it is ok, but nothing comes out from the computer when cranking the car.
Expert:  -Brad- replied 1 month ago.

I'm back at work today.. I see where you said you had 12v but no ground pulse.. That would mean the PCM is not sending the ground pulse and is likely bad. I attached the coil wiring for you.. If the wire is good I would replace the PCM,,

Customer: replied 1 month ago.
Hi Brad.
I just received and installed a new PCM and still don't get signals coming out of the computer to the coils.
Please let me know
Customer: replied 1 month ago.
Ey men, I still need help to resolve the issue with this car and I have not received response in more than 24 hours.

Related Dodge Questions