How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1704
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

Got a 2003 dodge ram 3500 (single wheel) cummins 24 v. had a

Customer Question

got a 2003 dodge ram 3500 (single wheel) cummins 24 v. had a problem with the ignition tumbler. key would go in but wouldn't turn. gave the key a tap with a rubber mallet and the sticking detents gave way to enable truck to start. changed out the tumbler and in lieu of bothering to code my old key to the new tumbler , i opted to just resign myself to use two keys . the key is not the coded type. got it put back together and reconnected the battery . it started fine . great. right?
cleaned up and put the tools away . truck would start but immediately cut off . tried again . it would only crank.
turned the key c. clockwise and then to start ... it would start but immediately cut off. try to start from off position and it would just crank. turn it again all the way c. clockwise , then to start ... it just starts and immediately cuts off . like clockwork each time.
tried disconnecting the batteries and waiting 30 seconds , then reconnecting ... same problem .
this is now the condition of the vehicle.
Submitted: 1 month ago.
Category: Dodge
Expert:  Chris replied 1 month ago.

Hello and welcome to just answer. Are you sure you do not have a SKIM security system in your truck? Can you send me the truck's VIN number?


Expert:  Chris replied 1 month ago.

Ok, if you are sure that the truck has no SKIM, then you may have a problem with the interface between the lock cylinder and the switch itself. Try removing the switch and operate it with a screwdriver. See if it will stay running.

Let me know.