How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Shop Foreman
Category: Dodge
Satisfied Customers: 12714
Experience:  Dodge/Cummins and Chrysler Certified Master Tech
12365498
Type Your Dodge Question Here...
Chris is online now
A new question is answered every 9 seconds

I have a 2002 dodge ram pickup, I changed the fuel pump and

Customer Question

I have a 2002 dodge ram pickup, I changed the fuel pump and relays I am still not getting any fuel pressure whats the problem ?
Submitted: 3 months ago.
Category: Dodge
Expert:  Juan Crespo replied 3 months ago.

Hi there.

Is the fuel pump getting any voltage? If not, is the relay getting energized?

Customer: replied 3 months ago.
the relay is getting is getting power and clicking but still no fuel pump energizing. also to note there is no ignition. fuses are good including the ASD relay which is clicking.
Customer: replied 3 months ago.
possibly the pcm/ecm?
Expert:  Juan Crespo replied 3 months ago.

If the fuel pump relay is getting power and clicking, then the PCM is doing its job. Is the anti-theft on?

Customer: replied 3 months ago.
if we cant get this ill call.
Customer: replied 3 months ago.
what about the no ignition? sprayed starter fluid in the throttle body and still doesn't attempt to start. like there is no ignition either
Customer: replied 3 months ago.
can't say i've ever seen this problem. fuel pump or wiring yes but no ignition too?
Expert:  Juan Crespo replied 3 months ago.

In order for me to be able to help you, I need you to you answer these questions:

  • is the anti-theft on?
  • with the engine cranking to start, what is the voltage at the fuel pump connector Dark Green/White wire?
  • with the ignition switch on, what is the voltage on the Dark Green/Orange wire going to any of the coils or injectors?
Customer: replied 3 months ago.
aren't aware of any antitheft or alarm. ill check voltage at both the pump and injectors
Expert:  Juan Crespo replied 3 months ago.

The truck is supposed to have an anti-theft system that includes a transponder key. You might try first using an original second or spare key to see if that solves the issue.

Customer: replied 3 months ago.
injectors are getting 12 volts. with the key turned on green wire with white tracer has 12 volts for less than a second and you can hear the fuel pump come on for a second. but checking the fuel pressure there is still none at the rail according to my gauge. The coils are getting nothing. Also the pump is getting 12 volts at cranking.
Customer: replied 3 months ago.
could it be a cps? that would effect the ignition but I still don't understand the fuel pressure issue. 12 volts at prim and pump runs and 12 volts at cranking.
Customer: replied 3 months ago.
ok, solved pump issue. system is pressurizing normally but now no fire/ignition
Expert:  Juan Crespo replied 3 months ago.

Ok. Did you check for codes? A bad crank sensor should have set a code.

Check voltage going to coils on Dark Green/Orange wire. If voltage OK, get a Noid Light (about $10 at most major auto parts stores) and check injector pulse. If voltage to coils and injectors OK, but no injector pulse and no ignition spark, replace crank sensor and retest.

Customer: replied 3 months ago.
replaced cam position sensor. still no ignition. Crankshaft sensor?
Expert:  Juan Crespo replied 3 months ago.

Are you even reading my posts?

Expert:  Juan Crespo replied 3 months ago.

I'm sorry, but I don't have anything else to contribute. I'll opt out so others may try. Please do not reply until another expert responds.

Customer: replied 3 months ago.
thank you
Expert:  Juan Crespo replied 3 months ago.

I appreciate you saying thank you, ***** ***** reply makes the site cycle your request back to me. Please do not reply until another expert responds.

Expert:  david craig replied 3 months ago.

Hi Im David, when you crank the vehicle, do you see the rpms jumping?

Expert:  david craig replied 3 months ago.

do you still need assistance?

Expert:  Chris replied 3 months ago.

Hello, my name is ***** ***** after reading your posts, I am thinking you have a failed crankshaft position sensor. The pump comes on and the ASD supplies votage for a few seconds, so that tells me the PCM is probably ok. The PCM will not re energize the ASD unless it sees a valid crankshaft position sensor. At this point I recommend replacing the crank sensor. Do that and let me know if she will now start.

Chris