How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1740
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

I have a 98 dakota that will not start and there is a

Customer Question

I have a 98 dakota that will not start and there is a clicking sound coming from behind the passenger side dash between the glove box and the door. There is a black plastic box that appears to be a relay or breaker mounted to the dash that is making the sound. Is this the central timing module?
JA: How many miles are on the car? Has the car been starting normally?
Customer: The truck has 305K and no, it will not start while the box is clicking. If and when the clicking stops, it will start.
JA: Are you fixing your Dakota yourself? What have you tried so far?
Customer: yes, the battery has been tested and cleared, I can touch this box and can feel the clicking from inside the box
JA: Anything else you want the mechanic to know before I connect you?
Customer: The problem started Friday, prior to that it ran fine. We have recently replaced the starter, battery.
Submitted: 3 months ago.
Category: Dodge
Expert:  Kevin Bourcier replied 3 months ago.

hello have you tried to boost it with another vehicle or a booster pack ? Did it quit while you were driving or did you turn it off and now it will not crank ?

Customer: replied 3 months ago.
we have tried to jump the truck with another truck and no it was not happening while we were driving it?
Expert:  Kevin Bourcier replied 3 months ago.

can youalways " crank " the engine over or does it not crank over ?

Customer: replied 3 months ago.
No, at this point it will not crank either? But the battery stills reads charged on a tester.
Customer: replied 3 months ago.
Hello, anybody there? I am unable to call due to lack of service in the area.
Expert:  Kevin Bourcier replied 3 months ago.

can youalways " crank " the engine over or does it not crank over ?

Customer: replied 3 months ago.
Same as above, no
Expert:  Kevin Bourcier replied 3 months ago.

2 or*****and what engine ?

Expert:  Kevin Bourcier replied 3 months ago.

sorry for the double send

Customer: replied 3 months ago.
4wd with 5.2ltr
Expert:  Kevin Bourcier replied 3 months ago.

automatic ?

Customer: replied 3 months ago.
automatic, it is an SLT model
Expert:  Kevin Bourcier replied 3 months ago.

okay , thanks

Expert:  Kevin Bourcier replied 3 months ago.

does everything else work ? headlights are on bright , radio , heater , blower all work ?

Customer: replied 3 months ago.
Kevin, I am not sure if you are trying to have multiple conversations at one time or not. But I cannot continue to wait this long between responses. Are you there?
Expert:  Kevin Bourcier replied 3 months ago.

okay . I will opt out . No . I am having a slow internet connection . I do apologize

Expert:  david craig replied 3 months ago.

Hi Im David and the first thing I need you to do is check the battery terminals for corossion and tightness. you also need to do the same for the positive cable at the starter. this isa very common issue on this vehicle. even if you think they are clean and tight please check them anyway. look at the large cable on the alternator also. the cables can also be corroded under the insulation.

Expert:  Amedee replied 3 months ago.

Hello! It looks like the previous experts opted out. If you still need help, please let me know!

Customer: replied 3 months ago.
Thanks, ***** ***** was too slow, took apart dash and discovered it was the CTM and i've ordered a new one
Expert:  Amedee replied 3 months ago.

Sounds good! I will be here if you have any further questions.