How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Auto Service Technician
Category: Dodge
Satisfied Customers: 24179
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
Type Your Dodge Question Here...
Pete is online now
A new question is answered every 9 seconds

I was hooking up one speaker wire when my break light ,and

Customer Question

I was hooking up one speaker wire when my break light ,and outside cargo light stop working ,and my radeo has no power to it. . Checked fuse they are all good
JA: Is the power loss consistent, or does it fluctuate?
Customer: Consistent . I turn my lights on and I have parking lights
JA: What year is your Cargo?
Customer: 1985 Dodge Ram 350. With a 360
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Checked all bulbs . Looked at all fuse. Looked under drivers side made sure all wires were not grounding out. Replaced light witch in dash and high beam switch on floor . Hoping I could fix it but not sure
JA: Anything else you think the mechanic should know?
Customer: Oh yes my blinkers only work if I pull the flasher out I have blinker switch in mail heading here when's
Submitted: 2 months ago.
Category: Dodge
Expert:  Pete replied 2 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Inspect in the area where you were connecting the speaker wire as well as to where the wire runs to to see if any connections have come loose needing reconnected or possibly repaired to correct this issue here.I have seen connections come loose in the past before and had to reconnect them or replace them for faults like this here.If this is or has been checked and found to be o.k. already let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 2 months ago.
I have checked the connections they seem to be ok I unplugged them then plugged them back in and still nothing.
Expert:  Pete replied 2 months ago.

Are both rear brake lights inoperative?

Customer: replied 2 months ago.
Customer: replied 2 months ago.
Could it be the switch on top of brake
Expert:  Pete replied 2 months ago.

O.k.,unfortunately after looking at my diagrams and info on this model here I do not show the correct diagram info I need on this myself but someone else here may be able to assist further.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Related Dodge Questions