How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 6760
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

Have a 2011 dodge4.7 103k miles. engine started missing code

Customer Question

have a 2011 dodge*****4.7 103k miles. engine started missing code reads #6 coil pack and throttle pos. sensor engine has the dual coil pack and spark plugs replace a number of the coil packs already + cleared comp. codes each time with no success. I noticed that 2 coil packs on each side are not firing eng. running on 4 cly. Do you have any ideas? thanks RON
Submitted: 3 months ago.
Category: Dodge
Expert:  -Brad- replied 3 months ago.

Good evening and welcome to JustAnswer!!

My name is ***** ***** I have worked for a Chrysler-Dodge-Jeep dealership for 19 years and I will do my best to help.

*****I work part-time here on JustAnswer to help you and other repair their own vehicles, and I get credited by your ratings.. So before leaving the site make sure and leave me a rating. You can still reply to me as many times as needed, even after the rating.. I will need for you to be my hands and eyes since I'm not there, and to be honest with today's electronics a scantool may very well be needed to retrieve the codes or to monitor data to see what's going on*****

Can you post back the exact P codes that are setting? This will give me a better idea on what;s going on and how to get it fixed..



Customer: replied 3 months ago.
cannot give exact codes at this time. mech. has left for the day codes or pretty direct # ***** or f coil pack and throttle positioning sensor. tried all possible causes to fix + clear comp. each time. something is causing 2 coil packs on each side not to fire. truck running on 4 cly. customer need vech. for work.
Expert:  -Brad- replied 3 months ago.

Ok just reply back when you have them.. Because I don't know what kind of circuit code your setting, shorted, open, closed, there are so many possibilities and when i know the codes I will then get an idea of what's happening..

Talk soon,


Customer: replied 3 months ago.
Went back got codes , p0113, p0123, p0306, p0300
Expert:  -Brad- replied 3 months ago.

Thanks for the reply!!

Ok great... Your codes are:






This engine uses TWO DIFFERENT types of spark plugs. A total of 16 plugs are used. The plugs are mounted in two rows (banks). The upper row (5) is used on the intake valve side of the cylinder head. The lower row (6) is used on the exhaust valve side of the cylinder head. The upper row (5) uses Bosch Nickel Yttrium plugs. The lower row (6) uses Bosch Iridium plugs. DO NOT INTERCHANGE THESE PLUGS.

The TOP row get replaced every 48,000 miles and the bottom row get replaced every 96,000 miles..

Have they both been replaced as required? If not I would start there and see if it resolves your P0300 and P0306. If they have then you will need to check for spark and fuel on #6 and if good then check compression as your missing one of them..

As for the P0113 and P0123 they are circuit high codes as in the voltage is higher than expected or you loosing the ground. I have attached both tests with wiring diagrams that will need to be followed to determine the issue..

If you need anymore assistance feel free to reply and don't forget the RATING before leaving the site!!

Have a great day,


Customer: replied 3 months ago.
Not really answer I'm looking for, truck was running fine started missing today as I mentioned lost fire on 4 coil packs at one time . I would think something has thrown it in limp mode. Or comp. or what ever controls firing on the coil packs became faulty. I dout if 4 coil packs or 4 plugs went out at the same time.
Expert:  -Brad- replied 3 months ago.

Per your codes it shows the engine is misfiring on #6 cylinder and multiple others. When you say you have lost fire do you mean you lost spark or 12v feed to coil? Which 4 coils are dead and does each coil have a constant 12v on one wire and a ground pulse on the other? I would start by checking #6 and for sure it's misfiring and see if it has spark and if not test the coil for 12v and ground pulse..

I have attached the complete coil wiring to help..

If you need anymore assistance feel free to reply and don't forget the RATING before leaving the site!!

Have a great day,


Customer: replied 3 months ago.
4 coil packs have no voltage at all.
Customer: replied 3 months ago.
As posted earlier I've already replaced # ***** and others with no improvement.
Expert:  -Brad- replied 3 months ago.

All of the coils share the same ASD 12v feed. You need to ohm the 12v ASD wires Brown/White to the ASD relay to find a broken wire..

Expert:  -Brad- replied 3 months ago.

I see you haven't rated yet which means I have not been credited for helping. Don't forget to honor your good faith deposit by rating my assistance..

Thank you and have a great day,


Related Dodge Questions