How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert R Your Own Question
Robert R
Robert R, ASE Certified Master
Category: Dodge
Satisfied Customers: 3932
Experience:  Dodge Master Certified, Dodge Sprinter Certified
49095596
Type Your Dodge Question Here...
Robert R is online now
A new question is answered every 9 seconds

Installed new federal mogul lifters 98 dodge 5.2 and they

Customer Question

Installed new federal mogul lifters 98 dodge 5.2 and they are very noisy. Should I have soaked in oil before installing?
Submitted: 5 months ago.
Category: Dodge
Expert:  K. Wiggins replied 5 months ago.

Hello, while it is a good idea to presoak hydrualic lifter in oil overnight they usually pump up in a short time. Did you install the lifters with the oil feed oil facing away from the cam?

Customer: replied 5 months ago.
I put them in W/ oil facing the valley not piston. As that is how the old ones came out Mark
Expert:  Robert R replied 5 months ago.

Hello, welcome and thanks for asking your question. My name is*****'m a Certified Auto Technician with 29+ years experience. I will do my best to assist you. please keep in mind that I may need to ask questions of you before I can answer. When you reply please feel free to add as much detailed information as possible pertaining to your concern.

If the lifters have been installed with the oiling holes pointing towards the cam or "Upwards", they are installed correctly. This helps to keep the oil from running out of the lifters during times that the engine is not running. If the oiling holse are pointing down, it will cause lifter noise for up to a minute during cold starts.. If this is the noise you are getting, make sure all lifters oiling holes are pointing up.

If the lifters have not pumped up after a couple of minutes with the engine running, you may not be getting enough oil pressure up to them. Have you tested the oil pressure yet?

Keep me posted...

Thank you,

Robert