How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask EricFromCT Your Own Question
EricFromCT, Dodge Technician
Category: Dodge
Satisfied Customers: 3315
Experience:  17 years experience
Type Your Dodge Question Here...
EricFromCT is online now
A new question is answered every 9 seconds

Last night when i got into my car - noticed there was no

Customer Question

last night when i got into my car - noticed there was no sound from the u connect system. radio works - made a call, but no audio
JA: Have you checked the fuses?
Customer: no is there a fuse for the amp and where would i find them
JA: What is the model/year of your Jeep?
Customer: its a 2011 dodge journey
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: yes - haven't tried anything yet - it was dark ou
JA: Anything else you think the mechanic should know?
Customer: out
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Jeep Mechanic about your situation and then connect you two.
Submitted: 3 months ago.
Category: Dodge
Expert:  EricFromCT replied 3 months ago.

Hi. Sometimes te u-connect system needs to be reset. I would first try to disconnect the battery cables, then touch them together, then after about 5 minutes, reconnect them to the battery and recheck the system. Is that something you can do?

Expert:  EricFromCT replied 3 months ago.

Hi. Were you able to get your u-connect system to work? DId you try the reset? Please let me know. Thanks.

Related Dodge Questions