How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1704
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

While driving 2010 ram 1500 around town, instrument lights

Customer Question

while driving 2010 ram 1500 around town, instrument lights all came on, wipers started up while switch was off, radio flashed on and off, turn signal idicators not working, fuel gauge read empty, speedometer quite working, door locks would not work.132,000 miles.
Submitted: 4 months ago.
Category: Dodge
Expert:  -Brad- replied 4 months ago.

Good morning and welcome to JustAnswer!!

My name is ***** ***** I have worked for a Chrysler-Dodge-Jeep dealership for 18 years and I will do my best to help.

I work part-time here on JustAnswer to help you and other repair their own vehicles, and I get credited by your ratings.. So before leaving the site make sure and leave me a rating. You can still reply to me as many times as needed, even after the rating.. I will need for you to be my hands and eyes since I'm not there, and to be honest with today's electronics a scantool may very well be needed to retrieve the codes or to monitor data to see what's going on...

If the wipers and headlights came on then you have experienced a BUS failure.. The BUS is the communication lines in which all the modules talk with each other.. The first step will be to read all the codes in the all of the modules to see what'c going on.. It could be a wiring issue it a bad module but you won't know until you read the codes with a scantool.. Can you post the codes here?

Customer: replied 4 months ago.
I will post the codes, but will not be able to do so till tuesday, the 14th.
Customer: replied 4 months ago.
I checked codes with scan tool, it reads 0 . After sitting for 2 days and disconnecting battery, it must have reset itself? Will scan again when it happens again and get back to you with codes. Everything seems to be working, but for how long. Thanks