How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert R Your Own Question
Robert R
Robert R, ASE Certified Master
Category: Dodge
Satisfied Customers: 3928
Experience:  Dodge Master Certified, Dodge Sprinter Certified
49095596
Type Your Dodge Question Here...
Robert R is online now
A new question is answered every 9 seconds

I have a 1999 dodge ram 1500 the cruise works but light

Customer Question

I have a 1999 dodge ram 1500 the cruise works but light won't come on. And 4x4 won't work
JA: Sometimes things that you think will be really complicated end up being easy to fix with Dodge. The Dodge Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer:*****wont work and light on dash won't come on. Cruise light on dash won't come on but cruise works. On a 1999 dodge ram 1500 extended cab pickup
JA: Are you hoping to fix this yourself?
Customer: Yes
JA: Great! What have you tried so far?
Customer: Checked fuses and looked at transfer case
JA: Is there anything else important you think the Dodge Mechanic should know about your Dodge?
Customer: No
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Dodge Mechanic about your situation and then connect you two.
Submitted: 6 months ago.
Category: Dodge
Expert:  HDGENE replied 6 months ago.

Hello, for the cruise since it works, just not lighting up the indicator it sounds like a bad bulb for the indicator in the insturment cluster. Do the 4x4 lamps turn on when you turn the key to on or start the vehicle?

Customer: replied 6 months ago.
No
Customer: replied 6 months ago.
the*****doesn't work at all either
Customer: replied 6 months ago.
The actuator when it's in*****it moves a little and when in*****it woby move
Expert:  HDGENE replied 6 months ago.

Ok you have to remove the instrument cluster to check the cruise bulb, so you can check them s well to see if they are ok. The 4x4 ones most likely are. They should light up when turning the key to on or crank to prove out. Otherwise an issue with a fuse for the 4x4 circuit or relay for the system may be at fault. Otherwise a diagnostic check on the 4x4 system would need to be done. Possible failed shift motor or module fault

Customer: replied 6 months ago.
What fuse is it. Where is it located
Customer: replied 6 months ago.
Nothing is marked
Expert:  HDGENE replied 6 months ago.

The fuse panel information I come up with only identify them as circuit numbers, not names for the circuits. Check all fuses in both power distribution and central junction blocks to rule out any fuse issues. It most likely is a fault with the 4x4 control system itself

Expert:  HDGENE replied 6 months ago.

Hello, do you need more help or information?

Expert:  Robert R replied 6 months ago.

Hello, welcome and thanks for asking your question. My name is*****'m a Certified Auto Technician with 29+ years experience. I will do my best to assist you. please keep in mind that I may need to ask questions of you before I can answer. When you reply please feel free to add as much detailed information as possible pertaining to your concern.

I am researching this concern for you and will get back with you as soon as possible, Thanks for your patience while I gather the information needed for your answer. Your understanding is greatly appreciated.

Please post a reply so that I know that you still need help with this..

Thanks,

Robert