How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 21436
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2012 ram 2500 Cummins with auto tranny an 4x4

Customer Question

Hi my name is***** have a 2012 ram 2500 Cummins with auto tranny an 4x4 currently has 73000 miles. I have the sinister egr\dpf deleted still running the muffler stock intake with the Edge with attitude set at stage 2 an the smarty programmer with timing set at stage6 so the issue is I parked it the other night after pulling my lil 17foot boat home from fishing it ran perfectly all day to work an back, however every once an a while my service air filter message pops up on the display I checked the filter an it look dirty but not terrible well the next morning went out started it to warm up before heading out an I noticed the exhaust sounded a lil different almost louder but also sounded restricted didn't think nothing of it so I drive down the dirt road about an 1\8 of a mile to the hard top about 5mph didn't notice anything unusual yet then as I'm pulling out onto the hard top I noticed my truck will not accelerate more then about 5mph so I pulled over dropped her into neutral an tried to rev it up an it wouldn't go much over 1000rpm so I shut her down let her site about 15min an fired her back up no problems well I go to take off again an still doing the same thing so I cruised back to the house trying to get her to get up an go well while I'm doing this I noticed my EGT where sky rocketing to over 1000° it was dark but I also noticed smoke pouring out my exhaust an like I said it was dark so I couldn't tell the color but either way I backed out of it really quick an even at an idle she was hitting around 600°+ an in park it was around 500°.... there's no miss or roughness no check engine light so I'm not sure where to start I think it may be plugged vane's in my turbo but I'm not sure so if anyone can help give ideas I would greatly appreciate the help!! Thank you!!
Submitted: 5 months ago.
Category: Dodge
Expert:  sprinkles08 replied 5 months ago.

Hello and welcome to JustAnswer!

The message was referring to the active air intake doors in the airbox and may have set due to an issue with the airbox itself, something foreign blocking movement of the doors, or software. This isn't likely related to the other issues but could possibly be if the intake was restricted.

Do you know what fault codes had set?

Related Dodge Questions