How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Dodge
Satisfied Customers: 23683
Experience:  2 Year Auto Diploma and Database Access
17871496
Type Your Dodge Question Here...
Dan is online now
A new question is answered every 9 seconds

Why do I have a miss fire under a load with my 2004 dodge

Customer Question

why do I have a miss fire under a load with my 2004 dodge stratus 2.7L flex fueled car? I've changed the plugs, coils, cam and crank sensor. the miss is worse when you turn on the accessories like a/c lights, and rear window defogger. I'm stumped. this thing runs great at idle, but as soon as you give it gas, the miss shows up?
Submitted: 7 months ago.
Category: Dodge
Expert:  Dan replied 7 months ago.
Hello, my name is***** the check engine light on? Does it act like you have a rpm limiter such as not wanting to go over 3000 rpm? Thanks.
Customer: replied 7 months ago.
no check engine light, if I full throttle it, it will go to the rev limiter. It seems that the rear bank coils have no effect when I un plug them. the front affect the idle when I unplug them individually. there's a odor of raw fuel from the exhaust and there's a slight back fire in the exhaust every once and a while.
Customer: replied 7 months ago.
did you get my last message?
Expert:  Dan replied 7 months ago.
then next step is to pull rear plugs and check to see if they are getting spark. If so, do a compression test on rear cylinders. Let me know results, thanks.
Customer: replied 7 months ago.
I changed the plugs, and did a compression check. 150 across the bank. if there is no spark, then is there a problem in the pcm? it's only on the rear bank it seems.
Expert:  Dan replied 7 months ago.
It could also be a wiring problem so if there is no spark check green wires for power. Let me know, thanks.
Customer: replied 7 months ago.
Well I checked for power at all of the coils and there is no power. I believe this system doesn't turn the power on until the run position is hit or starting.
Customer: replied 7 months ago.
Also, why is there an excess amount of oil in the intake of this car? is there a problem with the 2.7L engine with the pcv valve system?
Expert:  Dan replied 7 months ago.
The dark green/light green power wires all connect together on front/rear bank so if rear bank doesn't have power on those wires that means you need to follow wire to find break. With the oil in intake I'd start by replacing the PCV. Here is also a wire diagram related to injectors so you can see how it is wired. Let me know if you have more questions thanks.-https://www.dropbox.com/s/wpcf4t69jlz31zi/finj.pdf?dl=0

Related Dodge Questions