How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 6969
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
10114124
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

2003 hemi ram1500 199,000 miles came in on hook. runs

Customer Question

2003 hemi ram1500 199,000 miles came in on hook. runs bad...plugs were never replaced. had all cylinder misfire replaced plugs runs somewhat better. no misfire code had low fuel pressure 39lbs. replaced pump now has correct 48lbs still runs poor. had p2299 code from driving it with 2 feet to get here. did a throttle & acc pedal test both work together. we ran misfire counter test no spark misfire no codes now. vehicle doesnt have egr valve
this truck run fire just all of a sudden started to run bad
Submitted: 6 months ago.
Category: Dodge
Expert:  -Brad- replied 6 months ago.

Good afternoon and welcome to JustAnswer!!

My name is ***** ***** I have worked for a Chrysler-Dodge-Jeep dealership for 19 years and I will do my best to help.

I would start by doing a compression check on all the cylinders, the ones that are low pull the valvecover and inspect for broken valvesprings.. If the cylinder has low compression and the valvesprings are not broke then inspect the rocker arm to see if it moves as much as the rest of the cylinders beside it. To do this remove the ASD relay and jump the starter relay to watch the rocker arms move....

Customer: replied 6 months ago.
Compression. Low 130. High 150. Very fast right up to pressure. Under covers everything moves even
Customer: replied 6 months ago.
Still runs like crap. Compression was all good. Valve springs weren't broken what next
Customer: replied 6 months ago.
Still not running. Today I replaced the bed after fuel pump install. Tommorrow I hope I can devote more time to it
Expert:  -Brad- replied 6 months ago.

Sorry for the delay!!

If you erase all the codes and start it up how does it run? Does it still set the P0300?

Customer: replied 6 months ago.
Erase codes no different. No codes present at all. Drove it today 10 min only set o2 heat code.
Customer: replied 6 months ago.
Still not different. O2 heater code nothing else. Surges. Misses. But no codes. Tested all coils. Has new champion oe plugs. Wires were ohm tested. Next???
Customer: replied 6 months ago.
Today we were busy with other vehicles, didn't work on dodge. Any other ideas