How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Dodge
Satisfied Customers: 24720
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Dodge Question Here...
Pete is online now
A new question is answered every 9 seconds

SRT8: I have two vehicles I'm currently troubleshooting, the

Customer Question

I have two vehicles I'm currently troubleshooting, the first is the 09 SRT8 which I just need confirmation of my conclusion. The second is a 05 Ram with the 5.9 diesel
Submitted: 7 months ago.
Category: Dodge
Expert:  Pete replied 7 months ago.
Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay. Test each oxygen sensor wire with the wires disconnected from the PCM and sensors to see if any show a resistance to ground at all.Do this at the wiring harness side and not the sensor side.If there is a ground signal or resistance to ground with these unplugged this can indicate there is a short to ground in one of the wiring harnesses from the sensors to the PCM.If this is or was checked and found to be o.k. let me know so we can continue. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 7 months ago.
Yes, I have tested the resistance to all 16 wires from the PCM pigtail down to the O2 pigtail. Each wire has a resistance of. 02 +/-. 02.
Expert:  Pete replied 7 months ago.
Did you test resistance to ground on each wire though one at a time.The test you did shows the wire is good on each end with each other but if there is a short to ground the test you did wont show a short to ground unless you disconnect each sensor and the computer and test the resistance from each wire one at a time to ground to see if any are shorted to ground.If you find any shorted to ground the affected wire will need replaced or repaired. The black wires should have ground at all times at each sensor so this will read next to 0 resistance to ground.If you have any that do not read this then the grounds for the sensors are faulty and the wiring needs traced to locate the source of the ground issue and repaired from there.If any other wire shows resistance to ground then this does indicate that wire is shorted to ground and the wiring needs traced to locate the short and repaired from there. Let me know if you need anything else and feel free to rate my help here. Thanks Pete
Customer: replied 7 months ago.
I have tested for short to ground in the wiring harness, all of the wires have less than point zero two ohms of resistance. The four ground wires also tested without fault, I even unbolted and cleaned the connection then after reassembly tested the connection utilizing the "circuit" for the windshield washer pump and the reverse/back up lamps. With these sharing thier ground with two O2 sensors each I am confident I have a solid ground.
Expert:  Pete replied 7 months ago.
The only other cause I can see here then with these codes and all the testing done is either the PCM is programmed incorrectly and needs reprogrammed by a dealer to correct this for about an hours charge or the PCM is at fault and needs replaced then programmed by a dealer.I dont see any other causes for the codes set here.I have seen both either programmed incorrectly or defective needing replaced and programmed. Thanks Pete

Related Dodge Questions