How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Aftermarket & Factory Electronics
Category: Dodge
Satisfied Customers: 20698
Experience:  Cert. Dodge & Chrysler Warnty, Heavy Line Mech, Mobile Electronics. Sales, Installation & Repair for 30 years
1609972
Type Your Dodge Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Dodge Ram 2500: , I need help in resetting anti-theft system

Customer Question

Hi, I need help in resetting anti-theft system on my 2003 Dodge Ram truck.
Here is what I did…. I pulled out the instrument cluster to change out the light bulbs. My mistake was that I did NOT disconnect the battery, I know it is stupid but tooo late to get smart since it is done.
Here is what is happening now.
The cluster shows only the mileage, no gauges work or anything else.
Lights work, Radio works, interior lights work.
I do NOT have aftermarket alarm
I do NOT have remote door opening module or remotes
I DO have power locks
I have black keys which worked fine up to the moment I pulled out the cluster.
When I turn the key to the start position, it acts dead, turns off the radio and the instrument cluster mileage display.
Please help with advice, since it is a long tow to the dealer for me.
I have tried:
disconnection and re connecting the battery
Removing and reinserting the #51 fuse
Turning the door lock and unlock key on BOTH the driver and passenger side.
Submitted: 10 months ago.
Category: Dodge
Expert:  Don 'Mo Lurch' replied 10 months ago.
What Model Dodge Truck?What Engine?Manual or Automatic?Do you have a Test Light or Volt Meter & know how to use?
Customer: replied 10 months ago.
2003 Dodge Ram 2500
5.7L Hemi
Automatic Transmission
Yes I have and know how to use a volt meter
When I turn in the ignition NOTHING (except mileage and hazard warning lights) on the cluster work. When I go to start by turning the key to start mileage disappears and radio shuts down.
Thank you
Expert:  Don 'Mo Lurch' replied 10 months ago.
thanks for the added info...........Please be sure the Battery is Fully ChargedTest Voltage + on "both sides" of Fuses "PTC 2", "18" & "22" located in the Under Hood Fuse Panel with Key ONIF Voltage + is good, test the TAN (pin14), RED (pin 1), & BLACK / RED (pin13) wires of the Instrument Cluster with Key ONLet me know what you find
Customer: replied 10 months ago.
Battery: 12.5V
PTC2: 12.4V and 12.4V
PTC18: 12.2V and 12.2V
PTC22: 12.3V and 12.3V
On the gray plug with ignition off ON and the cluster removed
Pin 1: RED 12.6V
Pin 14: 12.8V
Pin 13: 0V Zero Volt
Customer: replied 10 months ago.
Sorry typo, yes I did have the key ON
Expert:  Don 'Mo Lurch' replied 10 months ago.
thanks.......PIN 13 should be BLACK / RED wireCan you verify that again with the Cluster plugged in & Key ON?
Customer: replied 10 months ago.
with cluster plugged in, Ignition key ON, pin 13 = OV (zere volt) on my truck the #13 wire is brown black (picture attached) ?
Expert:  Don 'Mo Lurch' replied 10 months ago.
I am showing "3" Plugs to the Instrument ClusterC1 Plug is a 26 PINC2 Plug is a 16 PINC3 Plug is a 26 PINSorry for the confusion, but I neglected to post Plug C3 PIN 13 BLACK / REDTo clarify..........Test the TAN (pin14) C3, RED (pin 1)C1, & BLACK / RED (pin13)C3 wires of the Instrument Cluster with Key ONagain....sorry for the confusion..........
Customer: replied 10 months ago.
12,3V on all (Pin 1, 13 and 14) on C1 plug and yes wire pin 13 is black/red
Expert:  Don 'Mo Lurch' replied 10 months ago.
Thank you for the info...........At this point it appears the Cluster is not communicatingHave you tried a Self Test on the Cluster?
Customer: replied 10 months ago.
No I have not started self test on cluster, my thought are that I have somehow tripped the Vehicle Theft security System
Customer: replied 10 months ago.
because when I turn the key on to start position it turns off the radio and the cluster was working fine. At the same time the are NO lights that come on in the cluster with the ignition key in on position
Expert:  Don 'Mo Lurch' replied 10 months ago.
Security would not blank out the ClusterSecurity Indicator would be OnWith the Cluster Plugged IN correctly, Disconnect the Battery Ground Cable for 1 minuteJumper or try another Battery to StartIF none of the above works, then you can try the Self Test:::This self test can be initiated manually by depressing and holding the trip reset button while cycling the ignition from the Off to the On position.During the self test, all of the PCI bus indicators will be illuminated. The speedometer, tachometer, fuel gauge, oil pressure gauge, coolant temperature gauge, and voltage gauge will position at their calibration points. The VF display will illuminate all segments and also display the software version. The chime will sound. When the self test is complete, the cluster will return to normal operation. Turning the ignition to the Off position or the cluster detecting engine RPM greater than 0 (zero) will stop the self test.::.IF still nothing, then you will need use of Dealer Scan Tool or equal to test Communicationapprx 1 hour laborlet me know what you find
Customer: replied 10 months ago.
Tried Jump starting, did not work.
The cluster does NOT go into self test mode.
Expert:  Don 'Mo Lurch' replied 10 months ago.
at this point you need use of Dealer Scan Tool or equal that can test Communication to the Instrument Cluster Module that is part of the ClusterYou have tested Voltage Inputs & Battery Voltage appears good.Sorry for the issue, but there are only a few things that would keep the Cluster from workinglet me know what happensthank you
Expert:  Don 'Mo Lurch' replied 10 months ago.
Please do the right thing and leave a rating, using the rating system, so I may be credited for this Q&A..NOTE: Do NOT Rate on how much TIME you waited, because I am not on 24 / 7 and I answer as soon as I see the question.The question will still remain open for follow up questions if needed..If for any reason, you can't rate my answer OKAY, GOOD, or EXCELLENT today.Please reply and let me know why, so I can help more/better..Rating is very Important to our Service.