How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 7511
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
10114124
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

I have a 2011 Dodge Durango Citadel with 5.7 Hemi V8 Engine.

Customer Question

Good morning.
I have a 2011 Dodge Durango Citadel with 5.7 Hemi V8 Engine.
Where is the coolant Sensor(s) located?
Submitted: 1 year ago.
Category: Dodge
Expert:  Randall C replied 1 year ago.

Hello, you wrote 2 different years, what year is the truck?

Customer: replied 1 year ago.
2011
Expert:  Randall C replied 1 year ago.

checking things, back shortly

Expert:  Randall C replied 1 year ago.

ok, I have attached a link for your review, it shows location, tells location, That sensor will have a violet/orange wire and a dark blue/dark green wire going to it

Customer: replied 1 year ago.
we read the control unit, the sensor says -27 degrees, with hot or cold engine
we changed the sensor under the intake, but still same problem
my dealer (here in germany) says there are two sensors, one for the control unit one for
the gauge
Customer: replied 1 year ago.
Ty, this Sensor we changed
Customer: replied 1 year ago.
Is it right that there are 2 Sensors??
Expert:  Randall C replied 1 year ago.

you did not mention this, You asked for location,I am going to opt out and open the post to the other experts

Customer: replied 1 year ago.
ty
Expert:  -Brad- replied 1 year ago.

Good morning and welcome to JustAnswer!!

Where are you reading the -27 degrees? In the overhead?

Customer: replied 1 year ago.
We read it with a scan tool for the control unit (ECM)
Expert:  -Brad- replied 1 year ago.

Did show -27 under engine coolant temp or ambient temp?

Customer: replied 1 year ago.
under engine coolant temperature
Expert:  -Brad- replied 1 year ago.

The coolant temp sensor is mounted in the waterpump housing, is this the one you changed? If yes then if you jump the 2 wires what does the temerature show?

Customer: replied 1 year ago.
we changed that sensor, the plug fits only in one position, if we dont plug, the temperature at the dashboard shows nothing, at the scan tool no changes
Expert:  -Brad- replied 1 year ago.

If you take a paperclip and jump the terminals what does the reading show? What codes are in the PCM?

Customer: replied 1 year ago.
No issue code at the PCM
Customer: replied 1 year ago.
If we jump it the electric goes dizzy
Expert:  -Brad- replied 1 year ago.

Was it a OEM sensor you used?

Customer: replied 1 year ago.
I can subscribe the whole issue.
If i drive the coolant temperature increase up to
240 degrees the falls down to 200, then up 240 again and that with one to two minutes rythem
Customer: replied 1 year ago.
yep oem mopar sensor
Customer: replied 1 year ago.
right from a dodge, jerp, chrysler dealer
Customer: replied 1 year ago.
Is that possible that there a second sensor is??
Expert:  -Brad- replied 1 year ago.

So the only problem your having is the temperature is rising from 200 to 240? Is the cooling fan coming on? And this is the only temperature sensor..

Customer: replied 1 year ago.
the cooling fan coming, the temperature drops down verry fast then, outsite temperature
50 degrees
Customer: replied 1 year ago.
if there only one sensor is there a issue with the controll unit? the sensor shows the right temperature at the dashboard
Customer: replied 1 year ago.
from 2011 till january 2016 everything was ok, the fan was only at hot summer coming and the temperature was stable, now it goes up and down every 2 minutes
Expert:  -Brad- replied 1 year ago.

OK are you low on coolant? Do you have any leaks? If you leave the radiator cap off does the coolant boil out?

Customer: replied 1 year ago.
no coolant leak, if the temperature teach 240
steam comes out the preasure valve at the radiator
Customer: replied 1 year ago.
perhaps a issue with the thermostat?
wich signal switches the thermostat, thecsignal from the temperature sensor?
Expert:  -Brad- replied 1 year ago.

Since you don't have any leaks I would have the radiator flow tested and replace the theromostat

Customer: replied 1 year ago.
Ok ty, we do it next.
Expert:  -Brad- replied 1 year ago.
You are very welcome !!Don't forget to rate!