How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1740
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

I have 08 durango that i purchased a few weeks ago. door

Customer Question

i have 08 durango that i purchased a few weeks ago. door locks have not worked since i bought the truck. switch does nothing, lock or unlock. The remote wont lock or unlock, but it will set the alarm when i hit the lock on it. Lights and horn beeps like its locked, lights flash when i hit unlock, but doors never lock or unlock. Thought maybe it was lock actuator, so i got 1 from auto zone, installed it on driver door. Didnt change locking or unlocking, but interior lights stayed on, light on dash said door was open. Put the orginal back on, lights went back out. i have the door panel off again today while im off work, testing power to lock actuator, not showing that im getting power. also, dont know much about the truck since we just bought it, but last couple times it has rained, noticed the driver and passenger seat belt is wet when you pull them out.
Submitted: 8 months ago.
Category: Dodge
Expert:  Jon replied 8 months ago.

Hi, does your Durango have a sunroof? If so, I'd start by removing the driver side kick panel and looking for water in the junction block. You may have to remove several of the connectors going to it and check for water in the connectors.

Customer: replied 8 months ago.
doesnt have a sunroof. I actually already have the kick pannel off, and have unpluged the connectors and everything. was googling, same somebody said to unplug the ctm for a few mins to see if the locks would start working again. they didnt
Customer: replied 8 months ago.
also checked the wires inside the door jam, didnt find any broke or anything
Expert:  Jon replied 8 months ago.

Ok, do you have a test light?

Customer: replied 8 months ago.
Expert:  Jon replied 8 months ago.

Ok, just to verify, check for power at the pink/yellow wire at both front door lock switches.

Expert:  Jon replied 8 months ago.

With the key in run, check those 2 wires I meant.

Customer: replied 8 months ago.
Ok, has power on both sides
Expert:  Jon replied 8 months ago.

Ok, the powers and grounds to the latches comes from the instrument cluster. I'm going to give you a few fuses that feed the cluster to check. Give me a minute or so while I look those up.

Expert:  Jon replied 8 months ago.

In the junction block in the kick panel, check fuse 9 (20A) , fuse 10 (15A) and 27 (30A) for power. They're all battery feeds to the cluster and should be hot at all times.

Expert:  Jon replied 8 months ago.

Fuse 19 (10A) should be hot with the key in run.

Customer: replied 8 months ago.
All fuses are good have power 19 with key on. My kick panel isn't showing fuse 27 and doesn't list any higher than 25 amp
Expert:  Jon replied 8 months ago.

I just zoomed on my diagram and I'm definitely showing a fuse 27 (30A) going to the cluster. I'll see if I can find where 27 is...

Expert:  Jon replied 8 months ago.

I see what you mean, I see a 26 and 29 but no 27, I'll keep looking.

Customer: replied 8 months ago.
Actually, most have been testing 3 for 9. Had 25 instead of 20, it was blown. Replaced it, they are working now
Expert:  Jon replied 8 months ago.

Ok, the diagram I had was showing fuse 27 in the junction block which is obviously wrong. you have a PDC and an IPM under the hood fuse 27 30A should be....Oh, ok, so you're fixed now?

Customer: replied 8 months ago.
Seems to be working fine now. Thanks for assistance. As far as the leak, I've read probably roof rack. What's the best way of solving this issue?
Expert:  Jon replied 8 months ago.

Ok, no problem, glad I could help. I haven't seen the roof racks leak, it's usually the sunroof equipped ones. Best Thing is to run a hose on the roof and try to locate where the water is coming in.

Customer: replied 8 months ago.
Ok, thanks
Expert:  Jon replied 8 months ago.

No problem.

Related Dodge Questions