How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1740
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

My issue: This morning I started my 2007 Dodge Nitro the oil

Customer Question

Hello My name is***** issue: This morning I started my 2007 Dodge Nitro the oil light came on. I checked the levels and it was good. got back in the truck, turned on the engine and no light came on. should I be worried?
JA: Thanks. Can you give me any more details about your issue?
Customer: I turned my vehicle on the low oil pressure light came on. I let the vehicle warm up because it was rather cold this am. I went about a 1/2 mile to the gas station. checked the oil and it didn't need any oil. I then got back in my truck turned the vehicle back on and the light didn't come back on
JA: OK got it. Last thing — Dodge Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 9 months ago.
Category: Dodge
Expert:  Tim Mohr replied 9 months ago.

Hi, my name is ***** ***** it the oil pressure light or the oil level low light?

Customer: replied 9 months ago.
just the oil pressure light
Customer: replied 9 months ago.
it hasn't come back on since yesterday morning
Expert:  Tim Mohr replied 9 months ago.

this can be caused by either a bad oil sending unit, or bad connection at the sending unit, are there any ticking noises or knocking sounds, when the light was on?