How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Dodge Technician
Category: Dodge
Satisfied Customers: 24447
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Dodge Question Here...
Amedee is online now
A new question is answered every 9 seconds

05 dodge ram won't start. instrument cluster goes haywire.

Customer Question

05 dodge ram won't start. instrument cluster goes haywire. Drains battery
Submitted: 10 months ago.
Category: Dodge
Expert:  Amedee replied 10 months ago.

Hello and welcome! My name is ***** ***** I can assist you with your question. What happens when you turn the key to the crank or start position?. Does it click once or multiple times?

Customer: replied 10 months ago.
Before the battery drains, I turn the key
the cluster panel blinks & clicks several times.
Expert:  Amedee replied 10 months ago.

What is the battery voltage at when this happens? How about the voltage on the fuses?

Customer: replied 10 months ago.
The battery was tested @ Autozone .The amps were around 630 & 12.37 volts
The battery loses power after repeat attempts . according to the voltage read out on the cluster is low
Expert:  Amedee replied 10 months ago.

Well, then the problem must be between the battery and instrument cluster. Chances are it is the TIPM under the hood. This is the power distribution center located on the left front fender. This part goes bad all of the time.

Expert:  Amedee replied 10 months ago.

Or you have a bad connection at the battery or just after the battery. Or even a bad ground.

Customer: replied 10 months ago.
I mentioned the problem to the person @
Autozone. They stated that the ground
maybe the cause but not the TPIM
Expert:  Amedee replied 10 months ago.

TIPM's go bad all of the time.

Customer: replied 10 months ago.
Okay l will replace the TPIM. Send me your email address so I can update you. Thanks for the info
Expert:  Amedee replied 10 months ago.

It is very expensive so I would do some checking/diagnosing before you replace it. Rule out all bad connections and bad grounds and then go after the TIPM as needed.

Expert:  Amedee replied 10 months ago.

I am glad I can help!

It has been a pleasure working with you. Please dont forget to honor your good faith deposit by rating my answer as "Excellent Service" for assisting you today.

Please let me know if you have any further questions.

Customer: replied 10 months ago.
Thumbs up Amedee
Expert:  Amedee replied 10 months ago.

:)

Expert:  Amedee replied 10 months ago.

Please dont forget to rate! Have a great night!

Expert:  Amedee replied 10 months ago.

I am glad I can help!

It has been a pleasure working with you. Please dont forget to honor your good faith deposit by rating my answer as "Excellent Service" for assisting you today.

Please let me know if you have any further questions.

Expert:  Amedee replied 10 months ago.

Hello! It's Amedee from just answer.

I am just checking in to see if you need any further assistance?

Let me know!

Expert:  Amedee replied 10 months ago.

.

Expert:  Amedee replied 10 months ago.

Hello! It's Amedee from just answer.

I am just checking in to see if you need any further assistance?

Let me know!

Expert:  Amedee replied 10 months ago.

.