How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim Mohr Your Own Question
Tim Mohr
Tim Mohr, ASE MASTER TECH
Category: Dodge
Satisfied Customers: 15114
Experience:  30 YRS EXPERIENCE, FOREIGN AND DOMESTIC, GAS AND DEISEL
17454363
Type Your Dodge Question Here...
Tim Mohr is online now
A new question is answered every 9 seconds

I'm having an etc issue, the truck will start and i drive it

Customer Question

i'm having an etc issue, the truck will start and i drive it down the street, it loses power and ETC light comes on. i can easily start i again within seconds. if i let the truck warm up for 10 to 20 minutes i can drive it with no problems. it's just driving the first time every morning that is really the issue. i replaced throttle body and MAP.... bad advice but i have to get this thing fixed. i had a friend that works on cars tell me to have battery checked because if not enough amps are coming through it could cause issues with electronic components
Submitted: 11 months ago.
Category: Dodge
Expert:  Tim Mohr replied 11 months ago.

Hi, my name is ***** ***** engine do you have in this

Customer: replied 11 months ago.
5.7l v8 - Hemi
Expert:  Tim Mohr replied 11 months ago.

Ok, these have a prticular problem, where the wire harness from the throttle body rubs on the a/c aluminum line, nd will cause this problem, have you pulled codes from the computer yet?

Customer: replied 11 months ago.
the first code was p0206 but i took the negative off battery when i put the throttle body on. that code went away and then i believe it was 1128 came up
Expert:  Tim Mohr replied 11 months ago.

the P1128 is for an oxygen sensor, are sure this is the code stored in this?

Customer: replied 11 months ago.
that's what the guy at autozone gave me
Customer: replied 11 months ago.
the code he gave me had a MAP as one of the possible causes as well as fuel intake in bank 2
Expert:  Tim Mohr replied 11 months ago.

ok first off, cn you check the harness coming out of the throttle body, it runs next to an aluminum a/c line, can you se if the harness has rubbed through on the line?

Customer: replied 11 months ago.
I'll go look now
Expert:  Tim Mohr replied 11 months ago.

let me know,Tim

Customer: replied 11 months ago.
It doesn't appear to have rubbed
Expert:  Tim Mohr replied 11 months ago.

ok,then the problem lies in the o2 sensor circuit for bank 1, most likely abad o2 sensor , upstream, but a partially plugged fuel filter can also cause this, has the fuel filter been changed lately?

Customer: replied 11 months ago.
I don't think so, i bought it used so i'm not sure.
Expert:  Tim Mohr replied 11 months ago.

then the fuel filter needs to checked next, and if it still set the code, then I would replace the upstream o2 sensor on bank 1,Tim

Customer: replied 11 months ago.
I'll try that, will i be able to contact you once i have that changed
Customer: replied 11 months ago.
is the fuel filter in the gas tank
Expert:  Tim Mohr replied 11 months ago.

Yes, it sits on the bottom of the fuel pump,Tim

Expert:  Tim Mohr replied 11 months ago.

and ys, after you rate me, you can come back at anytime, and ask follow up questions at no charge,Tim

Related Dodge Questions