How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 21594
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I HAVE A 2003 DODGE RAM 3500 RWD, DRW, 5.9CUMMINS. I WAS

Customer Question

I HAVE A 2003 DODGE RAM 3500 RWD, DRW, 5.9CUMMINS. I WAS DRIVING DOWN THE FREEWAY TODAY AND IT JUST QUIT. NOW WHEN I TURN THE KEY TO ON MY 4 GAUGES (GAS, OIL, TEMP AND ALT) WILL NOT WORK AT ALL AND THE DIMMER FOR THE DASH LIGHTS WILL NOT WORK, AND ALTHOUGH IT TURNS OVER IT WILL NOT START. I HAVE CHECKED ALL THE FUSES AND REPLACED THE ELECTRICAL PART OF THE IGNITION SWITCH (WITH BATTERIES DISCONNECTED OF COURSE) BUT STILL GET THE SAME RESULTS. THE 2 LARGER WIRE TERMINALS IN THE IGNITION SWITCH ARE SLIGHTLY BURNED BUT THE WIRES AND THEIR TERMINAL ENDS ARE NOT (I ASSUME THIS IS THE STARTER CIRCUIT). I HAVE ALSO REMOVED AND PROPERLY TIGHTENED THE PCM PLUGS (AGAIN WITH BATTERIES DISCONNECTED OF COURSE).
HELP!
Submitted: 1 year ago.
Category: Dodge
Customer: replied 1 year ago.
I ALSO CLEANED THE 4 GROUND BOLTS & EYELETS (3 ON THE DRIVER'S SIDE, 1 ON THE PASSENGERS) WITH A WIRE BRUSH.ALSO, HOW LONG IS THIS GOING TO TAKE?
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

If the engine will not start and the instrument cluster works but the gauges do not then the ECM is down. It could be down due to a lost power or ground, an internal failure, or a short to power or ground on several circuits.

Does the transfer pump run when the key is first turned on and do you hear the injectors clicking for about thirty seconds?

Customer: replied 1 year ago.
I HEAR THE INJECTORS CLICK. WHEN I TRIED TO START IT FIRST THING THIS MORNING THE GAUGES OPERATED (COLD CONDITION) BUT ONLY FOR A FEW SECONDS. IT WOULD HAVE STARTED IF THAT "CONNECTION" WAS KEPT. IS THERE A POSSIBILITY THERE IS A LOOSE WIRE IN THE IGNITION SWITCH HARNESS? THAT MAKES SENSE TO ME AND CAN YOU TELL ME THE COLOR OF THE WIRE THAT FEEDS THE 4 SMALL GAUGES ON THE DASH THAT COMES FROM THE IGNITION SWITCH?
Expert:  sprinkles08 replied 1 year ago.

There isn't a wire from the ignition switch to the instrument cluster. The gauges aren't working because the instrument cluster isn't receiving bus messages from the ECM.

Do you have an actual scan tool that will monitor data?