How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ric Your Own Question
Ric
Ric, ASE Certified Technician
Category: Dodge
Satisfied Customers: 152
Experience:  ase certified/certified chrysler/dodge specialist/30 years
31675116
Type Your Dodge Question Here...
Ric is online now
A new question is answered every 9 seconds

I have a 2003 dodge 5.9l cummins with P2509 power down lost

Customer Question

hi i have a 2003 dodge 5.9l cummins with P2509 power down lost and P0480 fan cluch and P0483 fan speed I replaced both batterys cleaned all connections including all grounds to motor and batteries and grounds on fender wells disconnected fan clutch connector still crank no start
Submitted: 1 year ago.
Category: Dodge
Expert:  Ric replied 1 year ago.

Good Afternoon....My name is ***** ***** i can assist you with your question...First...Do all the same codes re appear? Second...slide under the front of your truck and inspect the fan clutch wiring...It is probably cut.If the wiring is cut you will need to replace the fan clutch. As far as the no start...check the fuse block for any blown fuses and when checking the fan clutch wiring check for any bare wires touching each other and spread them apart so they do not touch...Then try starting your truck. If it is still a no start try spaying some WD-40 into the intake...If your truck starts and dies then you will have a fuel delivery issue....Try these first then we can proceed...Ric

Customer: replied 1 year ago.
FUEL RAIL PRESSURE DATA PID IS AT 85 PSI CRANKING RPM
Customer: replied 1 year ago.
TOOK FAN SHROUD OUT INSPECTED FAN WIRING ALL GOOD NO CUTS OR CHAFFING AT ALL AND ALL FUSES ARE GOOD TRYIED WD40 IT TRIED STARTING UP THEN DIED FUEL RAIL PRESSURE SENSOR IS AT 85 PSI CRANKING RPMS DISCONNECTED FAN CLUTCH CONNECTOR AND TRIED AGAIN STILL CRANK NO START
Expert:  Ric replied 1 year ago.

OK...Thanx...Cranking fuel pressure should be above 5600 (baseline pressure to start)... i suspect you have an injector allowing too much fuel return to the tank and not allowing pressure to build.

another issue related to this year of truck is the fuel pressure limiting valves can fail and cause a similar issue. Try unplugging the EFA actuator on the back of the injection pump it will allow the pump to provide full pressure to the injectors...It may sound horrible and knock but it will be ok...

Customer: replied 1 year ago.
UNPLUGGED THE EFA 2 WIRE CONNECTOR AT BACK OF PUMP AND STILL CRANK NO START AND DIDNT SOUND ANY DIFFERERENT AT ALL
Expert:  Ric replied 1 year ago.

Yeah ....it will clatter if it starts and runs this way. Since you have a no start with low rail pressure...loosen the banjo bolt on the top of the fuel pressure limiting valve...Just loosen the bolt....and crank the engine....If any fuel comes from the valve then it has failed and replace it....If not then you have an injector issue...Ric

Customer: replied 1 year ago.
where is that valve located at
Expert:  Ric replied 1 year ago.

It is the gold valve in the fuel rail next to the fuel pressure sensor...

Customer: replied 1 year ago.
I LOOSEND THE BANJO BOLT AND CRANK ENGINE NO FUEL AT ALL COMING OUT OF THE FUEL LIMITING VALVE
Customer: replied 1 year ago.
DO I JUST HAVE ALL OF THE INJECTORS REBUILT AND TESTED AT THIS POINT OR BUY ALL NEW ONES
Expert:  Ric replied 1 year ago.

I would replace all 6 and the connecting tubesRic. There are plenty of re man injectors out there...check with some truck shops near you...Look for shops that work on Cummins engines...NOT Dodge dealerships...too expensive....

Customer: replied 1 year ago.
OK I WILL LET U KNOW CAN I TAKE THEM TO A CERTIFIED INJECTION SHOP THAT CAN REBUILD THEM AND TEST THEM
Expert:  Ric replied 1 year ago.

Yes sir you can...Ric

Customer: replied 1 year ago.
O I FORGOT ONE CODE INITAILY STORED WAS PO219 CRANKSHAFT OVERSPEED CODE
Expert:  Ric replied 1 year ago.

Was this code cleared? Has it returned?

Customer: replied 1 year ago.
IT WAS CLEARED AND NO IT DID NOT RETURN
Expert:  Ric replied 1 year ago.

Great..In addition you should check you transfer pumps ability to get fuel to the injection pump. disconnect the rubber hose going to the injection pump and bump the starter...measure the volume for 10 seconds...It should be more than 500mls...any less and the transfer pump will need replacing also....

Expert:  Ric replied 1 year ago.

Good evening...Im just checking in to see how things are going?

Expert:  Ric replied 12 months ago.

Just checking in to see how you are doing....Fine i hope...If you need any more assistance please let me know...If not could you please rate my service when you get a chance...Thank You...Ric

Related Dodge Questions