How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 7380
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
10114124
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

I have a 2008 dodge 3500 4x4 quadcab dually, 6.7 cummins,

Customer Question

I have a 2008 dodge 3500 4x4 quadcab dually, 6.7 cummins, 150,000 miles, at 60,000 miles it had the turbo and torque converter replaced and whatever updates.I live in ND and winter has set in, -2 F this morning, I always have fuel filters changed in late fall , burn cenex roadmaster fuel, Do run howes diesel fuel conditioner in enter as well, never have jelled, truck starts at -20 without having block heater plugged in.
My problem tonight was strange, truck was warmed up, me and kids were heading to grandma's got 25 miles out of town and truck started losing power or so I thought, was going up slight hill and had it to floor to get 65 mph out of it, let off and pressed pedal down and could hear motor racing rpm would go up to 3000, mph was still going down, so we pulled over. Shut it off, looked under hood, oil and granny fluid ok, coolant ok, got back in started right up put in drive turned around to head home 2 miles down road alternator gauge dropped way down, then back up to normal, couple times, then sounded like belt or bearing squealing, check engine light comes on, overhead console display comes on says something like contact dealer immediately, pulled over again, shut it off looked under hood , belt was fine, did smell like some burnt rubber maybe? Got in started right up, drove it home 25 miles at 70 mph, had to acknowledge the console message 4 times.
I assume I will have to take this to the dealer and see what is going on, but seems kinda crazy to me. Any ideas?
Submitted: 1 year ago.
Category: Dodge
Expert:  -Brad- replied 1 year ago.

Good morning and welcome to JustAnswer!!!

I have read over your issues and when the alternator dropped it could be because the grid heater was coming on but it woudn't account for it running bad or the See Dealer message so at this point we will need to see what codes it has to determine the issue.. Have you had your batteries load tested? If you could get the codes read and post them all here would greatly help me.

Talk soon,

Brad

Tal

Customer: replied 1 year ago.
OK, Thanks Brad, will have to get it somewhere to get codes read, O'Rylies might do that if not our dealership is real slow so will have to see.
Thanks
Lowell
Expert:  -Brad- replied 1 year ago.

You are very welcome...

Once you get the codes post them here so I can see what's going on..

Brad

Customer: replied 1 year ago.
Codes from oreily came up as exhaust overtemp and particulate filter, the see dealer now warnings added exhaust filter 80 % plugged, I had to drive to a job site and in 60 miles it went to 100% full , power has been reduced.
Expert:  -Brad- replied 1 year ago.

I will need the actual P codes that are setting in order to determine the issue..