How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 21580
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have 2014 cummins with 18,000 miles, I removed the

Customer Question

Hello, I have 2014 cummins with 18,000 miles, I removed the silencer ring from the turbo, put everything back and about a month later it throws. Cel and the codes show crankcase ventilation system disconnected and my truck won't boost past 14 lbs then it suddenly drops to 8 and then back up, the truck acts sick. The dealership just erased the light and said everything was fine. Need help bad im worried I will ruin my new truck. Thanks
Submitted: 1 year ago.
Category: Dodge
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

You likely have a leak in the crankcase ventilation system. If the engine controller sees crankcase pressure is abnormal then it will set a fault code. The oil cap being left off, dipstick left out, or a closed crankcase ventilation hose left off will set a code.

What is the actual P code setting?

Customer: replied 1 year ago.
I'm thinking the code was p04bd, when I read the code it said " closed crankcase ventilation system disconnected". I took everything apart yesterday and checked the system, it's just that one hose that runs from the valve cover to the turbo and it didn't seem to be pinched or anything. The check engine light will go off for a day or two then come back on. Even if it was that it shouldn't cause lack of power and turbo surge should it? Even when the Cel light is off it acts weak and has that boost surge.
Customer: replied 1 year ago.
P04db was the code.
Expert:  sprinkles08 replied 1 year ago.

Do you have the VIN?

Customer: replied 1 year ago.
3c6ur5cL7eg277233
Expert:  sprinkles08 replied 1 year ago.

Are there any modifications to the air intake system?

Customer: replied 1 year ago.
Well like I orignally said I had taking the silencer ring out of the turbo compressor housing and I remove the internal round long filter that runs down inside the intake tubing, looks like a long cone. But other than that it's the stock air box that came from factory. Is there a chance that I didn't get the cold side of the turbo back on all the way and it is leaking around that?
Expert:  sprinkles08 replied 1 year ago.

Any leak in the intake tract will set this code but removing the components you did will also cause it. If there are no leaks I would recommend reinstalling the removed components and odds are the code will not return. This is either setting because of an actual leak or because flow isn't correct, which relies on the intake tract flowing as it was engineered. The piece you removed from the resonator is designed to direct intake flow correctly for the system to work.

Customer: replied 1 year ago.
Il try and put the resonator back in and see if that helps things any, thanks for your help I will respond back to you once I get it back in and let you know what happens. Thanks
Expert:  sprinkles08 replied 1 year ago.

You're welcome!

Customer: replied 1 year ago.
Well I put the resonator back and no change what so ever just less turbo noise, wide open throttle truck will only produce 13lbs of turbo boost. I'm clueless on what it could be. My buddy removed his silencer Ron from his and has had no trouble what so ever, you can't replace them because they are in with dowel pins that has to be drilled out to begin with. I really don't think the silencer ring is the issue though. So I'm back to square one?
Expert:  sprinkles08 replied 1 year ago.

What fault codes are currently setting?

Customer: replied 1 year ago.
Well right now my Cel is currently on and every time is has been checked it's been the code I sent you earlier p04db the crankcase vent disconnected. But like I was saying earlier there's just one hose and it's fine I've chexked it numerous times: is there a chance the filter is clogged this soon? At only 18,000 miles. Could there be a boost leak?
Customer: replied 1 year ago.
I just stopped at advance auto and used there scan tool and it now says p0102 mass or volume air flow A circuit low input and it also show p0106 manifold absolute pressure sensor
Customer: replied 1 year ago.
Erased codes pulled out started up a mountain and got into it hard check engine light right back on again
Expert:  sprinkles08 replied 1 year ago.

A boost leak would set a dedicated code.

The P0102 and 106 related to the lack of power. Are the MAP and MAF sensors plugged in?

Was the MAF sensor removed from the air intake at any point?

Is there anything aftermarket connected to any sensors under the hood?

Customer: replied 1 year ago.
I unplugged it when I took it back apart to put the baffle back in the intake tubing but put it right back when I was done.
Customer: replied 1 year ago.
No the truck is 100% stock
Expert:  sprinkles08 replied 1 year ago.

Was the MAF sensor removed from the air intake at any point?

Customer: replied 1 year ago.
Not that I know of. Just unplugged and put right back.
Expert:  sprinkles08 replied 1 year ago.

If the sensor was removed it could have been reinstalled backward. Otherwise you have a sensor or wiring issue, it could be the EGR flow control valve or an intake tract leak or a restriction anywhere from the MAF and inlet pressure sensors to the engine. If you're positive there isn't an intake tract leak that you caused by doing the work then I would recommend returning your dealer as the truck, minus the turbo, is under warranty. The CCV code isn't currently setting and isn't related to the symptoms you're having now, the MAP and MAF codes setting are what is putting the engine in limp in. These are the codes and freeze frame data they need to see and then diagnose.

Customer: replied 1 year ago.
Just between me and you the dealership I bought my truck at is a joke, they don't even a certified diesel mechanic. I think I'm gona have to take matters in my own hands and take it to a diesel performance shop even though il pay outta my own pocket somethin has to be done. Thanks for your help, sorry to bother ya.
Expert:  sprinkles08 replied 1 year ago.

It isn't possible they don't have someone certified unless they lost their tech recently and haven't yet gotten a replacement, there is a requirement for training in all areas. You can always go to another dealer if you have one close, your warranty is valid at any dealer.

Customer: replied 1 year ago.
I've been to 3 dealerships in my area and one of them has a diesel mechanic straight outta school but not Chrysler certified, the other two doesn't have one I promise. The guy who looked at it had no idea what was going on, he just cleared the code and said it was fine.
Expert:  sprinkles08 replied 1 year ago.

The corporation would restrict a dealer from ordering and selling diesel vehicles if they didn't have someone trained to the proper level in diesel repair and diagnosis areas.

Customer: replied 1 year ago.
Then they must have lied through there teeth to me, I took off work last Friday and drove to all three dealerships and had no luck at all. I'm gona get the truck completely deleted in two weeks the shop that's doing it is suppose to try and find the problem for me so I pray they can. I appreciate your help a bunch
Expert:  sprinkles08 replied 1 year ago.

I wish you luck with it!