How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 7610
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
10114124
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

2000 dodge 2500 P/U 5.9L gas no injector pulse DG/O no power

Customer Question

2000 dodge 2500 P/U 5.9L gas no injector pulse DG/O no power at the injectors or coil. I crank the motor I have spark add power at #87 on the asd relay I have power to all still doesn't run.
Submitted: 1 year ago.
Category: Dodge
Expert:  -Brad- replied 1 year ago.

Do you have any codes in the PCM? One of the main causes of no spark is a bad crankshaft sensor, have you replaced it yet?

Customer: replied 1 year ago.
no codes it has spark when I crank it. Key on to test power no power at coil or injectors
Expert:  -Brad- replied 1 year ago.

The PCM needs to see a crankshaft signal to turn on the ASD circuit. If you have spark when cranking then you should have injector pulse as well as spark from the coil.. The Dark Green/Orange is the ASD feed 12v that the coil and injectors share and they are controlled by the ground pulse from the PCM..

Now when your cranking do you have a constant 12v on the dark green/ orange wire to the coil and injectors? Also clip the test light to positive battery and probe the other wire and see if the test light flashes.. What is your fuel psi? Also with key on do you have 5v on the orange wire to the MAP/TPS?

Customer: replied 1 year ago.
Have 5v at tps. Constant 12 on green/orange wire when cranking and shows engine rpm on the scan tool. No ground side pulse when cranking thinking bad driver in pcm or the theft is turned on. Let me know what you think thanks.
Expert:  -Brad- replied 1 year ago.

There shouldn't be any security on your 2000 model so yes if your showing cranking RPMs with a scantool and there are no codes then I would replace the PCM to correct your issues.. Also the PCM will start and run with no programming but it will set codes until you have the VIN programmed...

Glad I could help and thank you for the positive rating,

Brad