How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1754
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

I have a 2005 dodge magnum and is not firing from the coil

Customer Question

I have a 2005 dodge magnum and is not firing from the coil packs
,where do I start to diagnose the problem
Submitted: 1 year ago.
Category: Dodge
Expert:  AZTechBrian replied 1 year ago.

Have you checked to see if there are any stored trouble codes?

Customer: replied 1 year ago.

P0222,P0480,P0481,P0685,P0688,P2101

Expert:  AZTechBrian replied 1 year ago.

What engine do you have?

Customer: replied 1 year ago.

5.7 hemi

Expert:  AZTechBrian replied 1 year ago.

I am going to opt out in case somebody has seen that combination of codes and knows what to make of it.

Expert:  bill replied 1 year ago.

ok first thing I would do is diagnose the p0685 and p0688 they are BOTH ASD (auto shut down relay or main relay fault codes, the asd relay is the relay that feeds the coils, injectors and many other things including the engine computer, if you have the vin I can send along the diagnostic procedure for those codes

Customer: replied 1 year ago.

2D4GV58225H587049

Expert:  bill replied 1 year ago.

here is a link to the diagnostics for the 2 codes I suggest you start with they are in word format and need to be downloaded and printed or saved fro your reference, the pins on the engine computer are very small so I strongly suggest you use "T" type needles to make any needed connections with your meter

https://www.dropbox.com/s/llfyio1m154lme1/p0685%2088.docx?dl=0

this site is on the honor system once you are satisfied with the service you rate it, you have already paid to use the site all a rating does is allow the expert to be paid for his time and that comes out of the fee you paid to use the service

Customer: replied 1 year ago.

Ok, is now firing but I have no fuel ,I changed the fuel pump because it liked terrible and had rust,I took the fuel line off the the fuel rail and tried to start the car and no fuel came out

Expert:  bill replied 1 year ago.

are those codes still setting?

the asd relay tells the computer to wake up and energize the fuel pump relay is there any power at the fuel pump?

you need to verify power and ground at the fuel pump

Customer: replied 1 year ago.

Asd,relay codes are gone, I do have ground at pump and I hear pump cycle on but does not pump fuel the remaining codes are, p0123,p0222,p0463,p0480,p02068,p2111

Expert:  bill replied 1 year ago.

if you hear the pump cycle but no fuel comes out is a bad pump OR no fuel in the tank, did you replace the correct pump, was it a module or did you replace JUST the motor, there is 1 pump and a syphon on the other saddle to transfer fuel from right to left is there actually any fuel in the left saddle?

p0123 is throttle position sensor voltage hi on sensor 1, this is part of the throttle body and if the sensor has failed the throttle body must be replaced

p0222 is throttle position sensor #2 short to ground again a redundant sensor and if bad needs a throttle body

p0463 is fuel level sensor circuit short to voltage

p0480 is cooling fan circuit #1 open or short

p2068 is fuel level sensor #2 circuit short to voltage

p2111 is electronic throttle unable to close

all of these could lead to a failing pcm but you will need a good scan tool to properly diagnose these codes and determine if the engine computer has failed or there is a wiring issue

Customer: replied 1 year ago.

Ok, I pulled the other fuel pump and the lines were busted I replaced the other pump and it started but it still is idle very badly,I saw some black stuff in the coolant system that maybe block seal, I'm going to do a compression test

Expert:  bill replied 1 year ago.

ok sounds like this car is a bit of a nightmare