How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Dodge
Satisfied Customers: 33468
Experience:  ASE Certs
7276279
Type Your Dodge Question Here...
Ron is online now
A new question is answered every 9 seconds

Roland I'm having issues with my Dakota which I've already

Customer Question

Roland I'm having issues with my Dakota which I've already typed out and just need to paste in.....is that OK?I have a 2003 Dodge Dakota 3.9 L quad cab with 185000 miles on it. During a 700 mile round trip it started developing a chaotic situation with the instrument cluster. It started with the Brake and ABS trouble lights coming on (with chime) and going off. As time passed it started to include all of the different trouble lights, gauges and odometer reading “No Bus”. They come on, go off but the truck runs without missing a beat. Shifts fine(although the gear shifter indicator blinks off and on), cruise control works fine, accelerates fine. Pretty much maddening. Tried replacing the cluster…same exact thing. Now while on the trip the engine did start running rough but couldn’t stop…got home to find the coil post on the distributer had broken….I don’t know how the truck kept running but it did. Replaced the cap and it runs fine…again. Only major repair preceding this was a
Submitted: 1 year ago.
Category: Dodge
Expert:  Ron replied 1 year ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

It appears you post was cut off so can you explain what type of problem you are still having and also have you hooked up a scan tool and retrieved the fault code and or codes that should be setting when the warning light cam on. Post back if your still need ing help and we can work from there.

Customer: replied 1 year ago.
Ron, I've entered the balance of the post and there are NO codes with the scanner. . Only major repair preceding this was a local shop replaced the fuel pump, filter sensor assembly in the tank. That was before I left and it made the trip to the destination without problem. Your assistance is appreciated.
Expert:  Ron replied 1 year ago.

Okay so what is the actual problem you are currently having?

Customer: replied 1 year ago.
Instruments and trouble lights blinking off and on including the odomenter which will display "no bus" then come back on. Chime rings every time. Brake light and ABS light seem to be more included than the others, but all are included. No stored codes. truck running fine.
Customer: replied 1 year ago.
sure seems like a short but I don't know where to start
Expert:  Ron replied 1 year ago.

In most cases if you are not getting any fault codes and the cluster is wigging out that usually means the cluster is failing. In most cases if the was actual a problem with any of the system you would get fault codes as well as running issues. This sounds like the problem is with the cluster.

Customer: replied 1 year ago.
My only problem with that Ron is that I did try a replacement cluster which was garunteed and had 135k on it and the exact same thing and pattern of dysfunction occured
Customer: replied 1 year ago.
Sorry if you missed that, it was in the first post
Expert:  Ron replied 1 year ago.

Okay then if that the case and the new cluster is not defective the the other most likely cause would be problem with the PCM (computer) . The next step would be to check the output on the BUS circuit. See the steps in the link below.

https://dl.dropboxusercontent.com/u/104923897/No%20Bus%20Nov%207.pdf

Customer: replied 1 year ago.
Will do, but there is going to be a delay for a day, I have a commitment through tomorrow afternoon, Ok if I get back to you then?
Expert:  Ron replied 1 year ago.

No problem, take as long as you need, Im here everyday .

Related Dodge Questions