How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Dodge
Satisfied Customers: 6878
Experience:  Since 1975
12769047
Type Your Dodge Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I have 2011 Dodge Ram diesel 6.7 and I have no power at all

Customer Question

Hi I have 2011 Dodge Ram diesel 6.7 and I have no power at all tried to jump it and nothing no lights or dash lights.
Submitted: 1 year ago.
Category: Dodge
Expert:  rpmdiag replied 1 year ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident we can resolve your problem together. Please understand that I don't know your skill level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in return. I will also continue assisting you after you have rated me, if necessary. If there is any reason I cannot get a positive rating, please let me know why “in advance”, so I can go another direction for you. I am sorry you’re having this problem; I’ll help you through it.

You first need to be certain that the batteries are charged fully and pass a load test. Then check all your cables and connections for corrosion. Hope this helps.

Thanks, Ron

Customer: replied 1 year ago.
Batteries are good connections are clean
Expert:  rpmdiag replied 1 year ago.

OK

Check the main fuse box under the hood near the battery on the left side for power going to it AND coming out of it. I even seen many times where a rodent has chewed through a wiring harness, so check for that too.

Ron

Customer: replied 1 year ago.
Wired look good going to and from the fuse box. I have power to my 12volt outlets and to my pump for my airbags and the engine hood light comes on when I lift the hood.
Expert:  rpmdiag replied 1 year ago.

OK,

You said before, no lights.

This sounds like you do have power in some areas and there is either a break or blown fuse somewhere.

Thanks again, Ron

Customer: replied 1 year ago.
no lights in the cab or dash or brake lights or headlights.
Expert:  rpmdiag replied 1 year ago.

OK

If all wiring and fuses are good, then we need to attach a scan tool and ping all the nodes to see where we're losing communications. In other words, one of the modules/computers isn't working.

Ron

Customer: replied 1 year ago.
I just tried the scanning tool and it won't read bc of no power to the plug or ignition
Expert:  rpmdiag replied 1 year ago.

Ok, then your problems are a little deeper. Y I y need to l I cat 5he module that's is shutting down the system. It can even be a gateway or the cluster causing it.

Thanks

Ron

Customer: replied 1 year ago.
All good I found a bad connection at power cable to the tipm, removed and cleaned and everything works.
Expert:  rpmdiag replied 1 year ago.

Good job, please dont forget to rate me too:)

Thanks

Ron

Related Dodge Questions