How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask -Brad- Your Own Question
-Brad-
-Brad-, Dodge Dealership Tech
Category: Dodge
Satisfied Customers: 6957
Experience:  16 Yrs Chrysler/Dodge Technician. ASE Master Certified(L-1)
10114124
Type Your Dodge Question Here...
-Brad- is online now
A new question is answered every 9 seconds

2010 dodge ram 6.7 sometime my service exhaust know see

Customer Question

2010 dodge ram 6.7 cumming sometime my service exhaust know see dealer comes on after about 2 min of running than goes away truck runs good the dealer told me to drive it for about 45 min and will go away sometimes two week than it starts again what does the dealer do to fix this
Submitted: 1 year ago.
Category: Dodge
Expert:  -Brad- replied 1 year ago.

Good afternoon and welcome to JustAnswer!! What codes are active in the ECM? Have you had the softwareupdated recently at the dealership? If you have over 65k miles, have you had the emissions cleaned yet?

Talk soon,

Brad

Customer: replied 1 year ago.
there is no code no message
Customer: replied 1 year ago.
no what is that
Customer: replied 1 year ago.
what do they do i have cleaned egr and put new crank case vent filter
Expert:  -Brad- replied 1 year ago.

Have you checked the codes with a scantool?

Has the software been updated at a dealership lately?

Also I see that you have replaced the CCF and cleaned the EGR, but did you reset the filter timer?

Customer: replied 1 year ago.
NO HOW DO YOU DO THAT
Customer: replied 1 year ago.
THE SOFTWARE WAS UPDATED MAYBE 2 YEARS AGO
Customer: replied 1 year ago.
MY SCAN TO SHOWS NOTHING
Customer: replied 1 year ago.
I NOTICE SOMETIMES WHEN I START IT WHEN ITS BEEN SITTING ALL NIGHT ITS LOUDER THAN USUAL THEN THE SERVICE EXHAUST MESSAGE COMES ON THAN GOES AWAY WHEN DRIVING.GOES BACK TO THE USUAL SOUND OK.
Expert:  -Brad- replied 1 year ago.

If you have not reset the CCF timer then follow this:

PERFORM SERVICE INDICATOR - RESET The “Perform Service” message will display on the EVIC each time you turn the ignition switch to the ON/RUN position to indicate a emission maintenance is required. To reset the “Perform Service” indicator system (after performing the scheduled maintenance) refer to the following procedure: 1. Turn the ignition switch to the ON position (Do not start engine). 2. Press and release the brake pedal two times. 3. Fully depress the accelerator pedal slowly two times within 10 seconds. 4. Turn the ignition switch to the OFF/LOCK position. NOTE: If the indicator message illumination when you start the vehicle, the “Perform Service” indicator did not reset. If necessary repeat this procedure.

Also if it's been 2 years since you had the software updated, I would highly suggest having the software updated to address several issues, and then perform a stationary desoot...

Hope this helps,

Brad

Customer: replied 1 year ago.
I TRYED THAT ALREADY THE MESSAGE GOES AWAY BUT THEN COMES BACK I THINK I WILL HAFT TO TAKE IT IN FOR DESOOT WHAT IS INVOLVE WITH THAT DO YOU KNOW WHAT IT COST MY WARRENTY RAN OUT LAST MONTH
Expert:  -Brad- replied 1 year ago.

We charge 1 hr which is around $105.00 to update the modules to the latest software, and of the service required still comes on then you will have codes in the module.. The update and stationary desoot should get you fixed..

Glad I could help,

Brad

Customer: replied 1 year ago.
THANK YOU I LIVE IN CANADA I WAS AT THE DEALER BEFORE AND THE DID THE SOFTWARE UPDATE BUT NOBODY SAID ANYTHING ABOUT DESOOT WELL THANK YOU FOR YOUR TIME I NEVER USED THIS BEFORE I WAS NOT SURE ANY THANK YOU.
Expert:  -Brad- replied 1 year ago.

You are very welcome..

Thank you for the positive rating,

Brad

Expert:  -Brad- replied 1 year ago.

You got a refund and didn't rate me?

Related Dodge Questions