How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1751
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

I'm getting an error code 51 52 13 on my 94 Dakota. Not sure

Customer Question

Hi George I'm getting an error code 51 52 13 on my 94 Dakota. Not sure how to fix it
Submitted: 1 year ago.
Category: Dodge
Expert:  Jim replied 1 year ago.

On this system we want to start with the smallest code, which is the code 13. Once we correct this problem if the other codes continue to return we will address those codes at that time. So start by making the following test.

Test the voltage at the Manifold Absolute Pressure Sensor (MAP) at key on, engine off. Normally at sea level it will be about 4.5 volts.
Start the engine and take a second reading of the MAP sensor voltage. With good vacuum supply getting to the sensor, the voltage will normally come down to about 1.3 volts.

Customer: replied 1 year ago.
I honestly pretty new to fixing trucks and most of the work has been done by me. I'm learning as I go, mostly by YouTube, so I don't know where the MAPS is on this truck
Expert:  Jim replied 1 year ago.

What is the engine size?

Customer: replied 1 year ago.
V6 3.9
Expert:  Jim replied 1 year ago.

Its on the left side of the throttle body.

Customer: replied 1 year ago.
Alright so I finally got that done. It's 4.9 with key on engine off and same with engine running
Expert:  Jim replied 1 year ago.

Is that the middle wire on the sensor you are checking?

Customer: replied 1 year ago.
I'm at work right now but, I checked both holes to beg and one was 4.9 and the other was 1.3
Expert:  Jim replied 1 year ago.

The middle one should be 1.3.

Customer: replied 1 year ago.
Expert:  Jim replied 1 year ago.

What kind of problems are you having with the vehicle besides the codes? and is the check engine light on all the time

Customer: replied 1 year ago.
No the check engine light comes on after a while of driving then goes off again when I turn the car off and back on. I can only describe the engine as stumbling after I get to around 55 then at anytime after that no matter the speed. Also I get about 100 miles to the tank