How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Dodge
Satisfied Customers: 24719
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Dodge Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2005 Dodge Ram 1500 Quad Cab Laramie with the 5.7L

Customer Question

I have a 2005 Dodge Ram 1500 Quad Cab Laramie with the 5.7L Hemi. I keep having an intermittent issue with the door chime dinging and the accessory power staying on even without the key in the ignition. I have replaced the key cylinder once and the ignition
switch module twice now, as directed by a Dodge certified mechanic, and I still continue to have the issue. Where else could the problem be? I also have some questions regarding the fuel system. Every once in a great while the engine will shut off right after
I start it. I just restart it and it runs kind of crappy for a few seconds and then runs fine. The truck has been tuned up by a Dodge dealership and it has a brand new fuel pump assembly in it. Could the throttle position sensor be going out or does it need
to be recalibrated as I have moved from high altitude to low altitude? I know the computer should automatically compensate for altitude but I know technology isn't also perfect.
Submitted: 1 year ago.
Category: Dodge
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Both of these issues here may be caused by the same reason.I have seen shorted electronic ignition switch wiring before cause an issue like this here with it needing repaired or replaced to correct this fault.If the ignition switch wiring has not been checked to see if it is damaged in any way or shorted this should be done.If this is done or has already been done and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.

Customer: replied 1 year ago.
Thanks for the response Pete. I'm not sure if the two problems are caused by the same thing, but I have in fact checked and rechecked for loose or shorted connections in the wiring harness. I have checked every connection point and traced every wire along the steering column from steering wheel to firewall and I haven't found anything. It just randomly starts doing the chiming, and randomly stops. It is possible that I may have missed something so I periodically go through and check the wires again. But as of now, I still can't find the issue.
Expert:  Pete replied 1 year ago.

Your welcome.

Was anything after market ever installed at all before this issue occurred?

Customer: replied 1 year ago.
The stereo head unit. It was fine for over almost two years. It just started randomly doing this over the past several months. I suspected it might have been the stereo at one point but I even replaced that and it's still doing it.
Expert:  Pete replied 1 year ago.

O.k.,this is a difficult question for me to answer myself from here with what is occuring.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete