How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Dodge
Satisfied Customers: 24657
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Dodge Question Here...
Pete is online now
A new question is answered every 9 seconds

Im working on a 5.9 common rail no power and black smoke

Customer Question

im working on a 5.9 common rail no power and black smoke when cutting out injectors 1,2,3, hardly change 4,5,6,change a good bit changed injectors 1,2,3 no change
Submitted: 1 year ago.
Category: Dodge
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Inspect and make sure the air inlet into the engine is free of any debris and that the engine air filter is clean as well.If these are o.k. on models that are equipped with a mass air flow sensor I have seen this sensor send incorrect readings causing this type of fault here needing either removed and cleaned or removed and replaced.If this has already been checked and found o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.

Customer: replied 1 year ago.
OK check these they are good had laptop hoooked up rail pleasure is changing up to 2000 psi at idle thinking sensor is bad also at full Throttle will only build 20000 psi on rail pressure
Expert:  Pete replied 1 year ago.

The rail pressure sensor can be a common component to fail and can cause an issue like this here.With the pressure reading jumping up like this here at idle this sounds like the component needing replaced.I have had to replace the sensor before on several models for this issue.This will cause poor running or running issues similar to this here.

Thanks Pete