How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Shop Foreman
Category: Dodge
Satisfied Customers: 13030
Experience:  Dodge/Cummins and Chrysler Certified Master Tech
12365498
Type Your Dodge Question Here...
Chris is online now
A new question is answered every 9 seconds

I have solved most of the problems on this vehicle but I

Customer Question

HI Chris, I have solved most of the problems on this vehicle but I have one interesting problem. The oil light does not go out when the vehicle is started. But if I turn it off and re start there is no light at koeo and no light with engine running. If
I wait some time this process repeats its self. I removed the oil sending unit electrical connector and I get the same results with no wire connected to the sending unit. I tested the sending unit for continuity at engine off and engine running and it seems
to be fine. It provides a ground when running but no ground when off. What do you think the problem is? Thanks, Val
Submitted: 1 year ago.
Category: Dodge
Expert:  Chris replied 1 year ago.

Hi Val! That is an interesting problem. Don't think I have seen this before. Let me pull up the wiring diagram and look it over. I will then get back to you asap.

Chris

Customer: replied 1 year ago.
Hi Chris, Did you find the diagram of the wiring for the Oil Light?
Expert:  Chris replied 1 year ago.

No, sorry, I was out of town for a while but will try to do that tomorrow Val.

Chris

Customer: replied 1 year ago.
That's ok, take your time. Its low on the list as I had to give back the vehicle for the next 10 days.
Expert:  Chris replied 1 year ago.

Hi Val, According to the wiring diagram, the oil pressure switch is wired to the PCM (engine computer). The PCM then sends a message to the instrument cluster to turn on or off the oil light. Now you say that the switch shows a ground with the engine running? It should be the other way around according to the service manual. Can you recheck that when you get a chance?

Chris

Customer: replied 1 year ago.
OK, I will check the sending unit. But can you tell me what wire and what the signal is going to the instrument cluster? Is it a constant voltage or something else. is something switching in the instrument cluster to turn the light off and on?
I'm beginning to question the cluster. I also need to pull it to check the blinker lights because I have none. Does the BCM have anything to do with this?
Expert:  Chris replied 1 year ago.

Val there is no dedicated wire from the sending unit to the cluster. The PCM (engine computer) is wired to the sending unit and then sends the information to the cluster over the BUS network.

Chris