How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Your Own Question
Chad
Chad, Lead Master Tech
Category: Dodge
Satisfied Customers: 1114
Experience:  Electrical Master,Diesel Specialist, Lead Tech/shop foreman
12781541
Type Your Dodge Question Here...
Chad is online now
A new question is answered every 9 seconds

No started and appeared (no bus) on speedometer what is

Customer Question

no started and appeared (no bus) on speedometer what is problem and how may I solve that ?
Submitted: 1 year ago.
Category: Dodge
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Chad replied 1 year ago.

Hello, do you still need assistance?

Customer: replied 1 year ago.
my question are (99dodge ram1500 5.2liters,no spark,no injector signal also appeared ( no bus) on speed ohmmete
Expert:  Chad replied 1 year ago.

OK, first thing I need you to do is unplug the crank sensor and turn the key to the Run position and tell me if the cluster still says No Bus.

Customer: replied 1 year ago.
Unplug crank sensor kEu on still no bus
Expert:  Chad replied 1 year ago.

Ok, I was hoping that was not the case.

You are going to need a new PCM.

The only two things on your vehicle that can cause this concern is a shorted crank sensor or a bad PCM.