How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1751
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

I'm trouble shooting "no bus" on odometer. Plugged in cheap

Customer Question

John
I'm trouble shooting "no bus" on odometer. Plugged in cheap scan tool it says no link. I assume that means no power to control unit or chips fried. Worked when I parked it.
Submitted: 1 year ago.
Category: Dodge
Expert:  Wayne Crawford replied 1 year ago.

Hello. My name is ***** ***** I will be helping you today.

Do you have a multimeter? Youre right it does mean a module isnt powering up. We need to check the power and ground wires.. a lot of times when something of this nature happens after a vehicle has been sitting its because some critter decided wiring insulation would make a good nest material.

Customer: replied 1 year ago.
I drove it the day before and parked it. Yes I have multimeter. I have already unplugged individually map, tps, crank, trans, can, sensors and cycled ignition. No luck. I'm going to check grounds next.
Expert:  Wayne Crawford replied 1 year ago.

What year and type of vehicle are you working on as well as engine size?

Customer: replied 1 year ago.
2003 dodge 2500 van 5.9 v8
Expert:  Wayne Crawford replied 1 year ago.

Load test the power and ground circuits at the PCM with a headlight bulb. I am attaching a connector view which shows which ones are power and ground.

Customer: replied 1 year ago.
Ok with (12v load bulb) tested terminals. 2 no power, 22 power, 31 and 32 are grounded. 17 didn't light up bulb at all.
Customer: replied 1 year ago.
fuse 6 is good
Customer: replied 1 year ago.
Ok, update. Decided to recheck with ignition on, da. 2 is good. 17 nothing. Is that 5 volt out of PCM? It is sounding like PCM,dead.
Customer: replied 1 year ago.
It is going to salvage tomorrow
Expert:  Wayne Crawford replied 1 year ago.

Sorry about the delay. I had to go out of town a few days. Do you still need help? Sounds like you scrapped it.

Related Dodge Questions