How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 21571
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

GRANSCARAVAN: NEW CLUSTER INSTALLED STILL NOTHING

Customer Question

NEW CLUSTER INSTALLED STILL NOTHING
Submitted: 1 year ago.
Category: Dodge
Expert:  sprinkles08 replied 1 year ago.
Hello and welcome to JustAnswer! I'm assuming the instrument cluster is not coming on when the key is turned on. If the cluster is completely non responsive then the problem is either in the cluster or a loss of power or ground due to a wiring issue or blown fuse. If the cluster circuit board has been replaced with a new part then you should be able to rule it out. What actual symptoms are you having?Have the cluster powers and grounds been tested?
Customer: replied 1 year ago.

YES ALL FUSES ARE FINE WE THINK WE FOUND IT A BAD WIRING HARNESS TO THE CLUSTER OK

Expert:  sprinkles08 replied 1 year ago.
Great!