How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 21989
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Ram 1500: My truck idle surges when I'm at a light or in park,

Customer Question

My truck idle surges when I'm at a light or in park, also I have lack of power and going up hill I need to give it enough gas to go into passing gear to maintain speed. While doing so, it's like in not pushing the gas pedal until it shifts into passing gear. Fyi I had the intake cleaned and it seemed better for a couple hours but that's it.
Submitted: 1 year ago.
Category: Dodge
Expert:  sprinkles08 replied 1 year ago.
Hello and welcome to JustAnswer!
Depending on which engine you have you may have a single cause for both problems. An erratic throttle position sensor will cause idle fluctuation and it can also cause trans shifting issues because the trans controller needs to see an accurate signal from the TPS to control up and downshifting.
Which engine do you have?
Have you checked for fault codes?
Customer: replied 1 year ago.
4.7 slt, and no codes.
Expert:  sprinkles08 replied 1 year ago.
Try disconnecting the TPS when the idle is fluctuating. If disconnecting it settles the idle down then replace the sensor.
Customer: replied 1 year ago.
Ok so I decided just to change it (it was only 20) it seemed better for a little while but but now it's back
Customer: replied 1 year ago.
Also now I have a p0113 code
Expert:  sprinkles08 replied 1 year ago.
The P0113 is setting because the intake air temperature sensor was unplugged with the key on.
Does the idle settle down with the TPS unplugged?
Customer: replied 1 year ago.
It did, could it be a bad tps?
Customer: replied 1 year ago.
How do I get the code off I tried pushing trip while turning key on also took the battery off
Expert:  sprinkles08 replied 1 year ago.
If the code is still present after disconnecting the battery then the problem is still present. Either the sensor is still unplugged, the connector isn't seated or the terminals are damaged.
If the idle goes to normal with the TPS unplugged then the problem is either the sensor or a poor connection at the sensor. You can try wiggle testing the connector, if you can move the connector and change the idle the connector will need to be replaced.
Customer: replied 1 year ago.
Sorry it took so long to get back to you it's been crazy at work... So here's an update. I got a new tps and it stoped surging also I was able to get all codes off. But I still am having a hard time with acceleration, up hill,mostly. so as I'm comming to the bottom of the hill I'll be at 70 mph and as I go up I loose a lot of speed 10 mph or so, as I push the gas to accommodate speed, it does nothing( doesn't pick up speed rpm stays the same) unless I push hard enough to go into passing gear. any ideas?
Expert:  sprinkles08 replied 1 year ago.
How long have you had the truck?
Is it acting differently now than before if it's driven identically and in the same places?
Customer: replied 1 year ago.
I've had it for a year, it's hard to say, I travel for work and don't spend much time in one place.
Customer: replied 1 year ago.
I never noticed anything until I drove from Minnesota to Texas
Expert:  sprinkles08 replied 1 year ago.
You're positive that what you're feeling now wasn't there before? It will take quite a bit of throttle in some cases to force a downshift.
Customer: replied 1 year ago.
Yes, it does nothing until I push the throttle hard enough to going to passing gear, I took A video of it but am on able to upload it
Expert:  sprinkles08 replied 1 year ago.
There is no throttle response until it downshifts? No change in engine tone?
Customer: replied 1 year ago.
Exactly
Expert:  sprinkles08 replied 1 year ago.
It has been driven more than twice and no codes are currently setting?
Customer: replied 1 year ago.
Yeah, I drive everyday for work and I've driven 400 miles one way
Customer: replied 1 year ago.
No codes
Expert:  sprinkles08 replied 1 year ago.
Do you have a scan tool to monitor data?
Have you tested fuel pressure wen this is happening?
Customer: replied 1 year ago.
I do not
Expert:  sprinkles08 replied 1 year ago.
Have you tested fuel pressure while the problem is happening?