How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 22523
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Dodge van ram 3500: Dodge van 3500 i lost power to instrumentclust

Customer Question

Dodge van 3500 i lost power to instrumentclust light and radio and mirror check all fuse in bx is there a relay
Submitted: 2 years ago.
Category: Dodge
Expert:  sprinkles08 replied 2 years ago.
Hello and welcome to JustAnswer!
The park lamp circuit is directly powered by the headlamp switch without a relay. Power leaves the switch and goes to the park lamps and back through a second, smaller fuse for interior illumination.
If illumination doesn't work but the park lamps do and fuses are good then it would have to be a wiring issue. A blown fuse is far more likely.
The illumination fuse is fuse 20 in the box inside, a 3 amp. You've tested or replaced this fuse?
Customer: replied 2 years ago.
I have no power to fuse 20 in the inside box. I have no radio, no fans, no electric mirror function, also. The power door windows and locks work. Can' t figure out where the live wire is to feed fuse 20. What block does it come from?
Expert:  sprinkles08 replied 2 years ago.
I wasn't aware that the blower motor and radio were not working. These items stopped at exactly the same time as the illumination?
Customer: replied 2 years ago.
Yes. I lost everything at the same time. I changed the battery and it sparked when I reconnected it. Nothing has worked right since.
Expert:  sprinkles08 replied 2 years ago.
Was polarity reversed or the key left on when reconnecting the battery?
Customer: replied 2 years ago.
Sorry for the delay. We are on vacation and don't always have internet. No to both of the above issues.
Expert:  sprinkles08 replied 2 years ago.
You're testing for power at fuse 20 with the headlamps on and dimmer turned up?
Customer: replied 1 year ago.
Yes
Expert:  sprinkles08 replied 1 year ago.
Do you have power on the pink/red wire at the headlamp switch?