How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 22121
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Dodge advenger: I have a 2010 dodge advenger the radio started

Customer Question

I have a 2010 dodge advenger the radio started loosing power Turing off then coming back on then my ac stopped working blowing hot air. There is a light that came on that reads abs then my battery light came on then the engine light. At the stop sighn it was slow taking off and when I did get to 50 mph it sounded like it was reving up. And the rpm was on 5 when I got home and put it in park it started shaking . so turned it off and now its completely dead. No lights no nothing
Submitted: 1 year ago.
Category: Dodge
Expert:  MoparHeat replied 1 year ago.
Hello! Thank you for your inquiry. My name is ***** ***** I will be assisting you...
The first thing you need to do in this situation is have the battery and alternator tested. You could also first try charging the battery or see if the vehicle will jump start. If you can get the engine started you can test for alternator output at the jump start posts under the hood. Using a voltmeter connected to the jump start posts the voltmeter should read 13.5 - 14 volts if the alternator is working properly. I would focus on the battery first as you need to ensure the battery is good before attempting anything else. If it won't jump start or the battery won't take a charge then this will most likely be a bad battery. The battery on these is in the left front bumper in front of the driver's front tire.
Please charge and/or test the battery and let me know what you find. Thank you!
Customer: replied 1 year ago.
Ok it jump started but it won't hold a charge. But while I had it running the radiator started overflowing
Expert:  sprinkles08 replied 1 year ago.
Hello and welcome to JustAnswer!
With all of your symptoms happening together I would first suspect the belt is off. If the belt is off it will overheat because the water pump isn't being turned, it won't charge because the alternator isn't turning.
Your question has been open for a few days. Did you get the problem resolved?

Related Dodge Questions