How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Crawford Your Own Question
Wayne Crawford
Wayne Crawford, Shop Owner
Category: Dodge
Satisfied Customers: 3904
Experience:  MO Safety/Emissions Certified on all makes and models with a strong electronics background aiding in electrical troubleshooting.
66997337
Type Your Dodge Question Here...
Wayne Crawford is online now
A new question is answered every 9 seconds

Dodge RAM 2500 4x4: i have a dodge ram 2500 2003 which will

Customer Question

i have a dodge ram 2500 2003 which will not idle correctly even at redlight. i finally got a code out of it today snd it says p0341 open circuit lf...what does that mean
Submitted: 1 year ago.
Category: Dodge
Expert:  Wayne Crawford replied 1 year ago.
Hello. My name is ***** ***** I will be helping you today.It usually means the cam sensor is bad. Sometimes its the wiring to the cam sensor. Do you have a multimeter for testing?
Customer: replied 1 year ago.
Yes I have multimeter
Expert:  Wayne Crawford replied 1 year ago.
Unplug the cam sensor just below the injection pump. Check for 5 volts on the Dark Green/Orange wire and on the Dark Blue/Red wire. Check the Light Blue/White wire for a good ground. Let me know what you get on those.There is also a TSB for reflashing the ECM to address this but that is when its intermittent.
Customer: replied 1 year ago.
I have looked for sensor...can not locate it....is it behind power steering pump
Expert:  Wayne Crawford replied 1 year ago.
I am attaching a location on it. Just click on the link. Thanks
Customer: replied 1 year ago.
Thank u....i found it....do I have to remove anything else to remove it
Expert:  Wayne Crawford replied 1 year ago.
No problem.You do not need to remove anything else.Disconnect electrical connector at CMP sensorRemove sensor mounting bolt.Carefully twist sensor from timing gear housing.Check condition of sensor o-ring.
Customer: replied 1 year ago.
I replaced sensor....have not checked voltage yet.....no change in bad idle.....it idles about 800 drops to bout 400 surges to 1200 back to 800 and then repeats cycle until motor warms up
Expert:  Wayne Crawford replied 1 year ago.
I never suggested you change it.

Related Dodge Questions