How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Dodge
Satisfied Customers: 1740
Experience:  ASE Master tech, 30 years exp. troubleshooter, driveability tech
2947720
Type Your Dodge Question Here...
Jerry is online now
A new question is answered every 9 seconds

Neon: The generic evap system code is flashing on my 2005 Dodge

Customer Question

The generic evap system code is flashing on my 2005 Dodge Neon. I have replaced the evap solenoid and the vapor canister but the light is still on. Should I try replacing the hoses to the vapor canister? Do you have any other suggestions?
Submitted: 1 year ago.
Category: Dodge
Expert:  Chris replied 1 year ago.
Hello, my name is***** you for allowing me to assist you! Did you replace the Leak Detection pump also? Did you check for any leaking hoses?
Chris
Expert:  Chris replied 1 year ago.
Hello, just checking back to see if you received my last reply, and if so do you still need help with your problem?
Chris
Expert:  Chris replied 1 year ago.
Hello, just checking back to see if you received my last reply, and if so do you still need help with your problem? Please remember, the website will not automatically credit me from your deposit or subscription without your Rating! Please, use the Rating System Box and Rate our Q&A session today or. If you need to ask more questions, please feel free to ask!
Thank you!
Chris
Customer: replied 1 year ago.
I just replaced the leak detection pump the light is still on. I have yet to check the hoses but when I replaced all of the parts the hoses did not appear to be cracked. I will take a closer look in the next couple of days.
Expert:  Chris replied 1 year ago.
Did you clear the code?
Chris