How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert R Your Own Question
Robert R
Robert R, ASE Certified Master
Category: Dodge
Satisfied Customers: 3933
Experience:  Dodge Master Certified, Dodge Sprinter Certified
49095596
Type Your Dodge Question Here...
Robert R is online now
A new question is answered every 9 seconds

Dodge: Robert . I have a 05 dodge 5.9 in the morning when

Customer Question

Hi Robert . I have a 05 dodge 5.9 in the morning when I start it blows a litte white smoke seems like maybe the motor missed once or twice I took it in and had it scoped and they said the number 4 injector was bad so they put a new one in and it's still doing it plz help
Submitted: 1 year ago.
Category: Dodge
Expert:  Robert R replied 1 year ago.
Hello, welcome and thanks for asking your question. My name is***** a Certified Auto Technician with 27+ years experience. I will do my best to assist you. please keep in mind that I may need to ask questions of you before I can answer. When you reply please feel free to add as much detailed information as possible pertaining to your concern.
How many miles on the vehicle?
Has it been scanned for codes? If so, can you post any codes that were retrieved here?
Keep me posted...
Thank you,
Robert
Customer: replied 1 year ago.
110,000 miles I've done the key trick no codes
Customer: replied 1 year ago.
Just used my pocket scanner one code p2509
Expert:  Robert R replied 1 year ago.
It is very possible that a failed injector could have caused engine damage.
There is a simple test that you can do to see if there has been damage done to the cylinder causing loss of compression.
When cold after an overnight sit. Raise the hood and remove the oil fill cap and lay it nearby. Go in the vehicle and start the engine. While starting engine, look to see if you notice large puffs of smoke coming out the oil fill hole with the engine idling. IF you see smoke (larger amounts) it is a sign that you have blowby and a loss of compression. A good way to tell if this is excessive is to go ahead and get the oil fill cap and just set it over the opening and see if the engine builds enough internal pressure to push the cap off the opening or rock the cap up and down while idling. If the cap moves off the opening it is a sign of excessive blowby.
IF you find this condition during the cold start, chances are good there is internal engine damage. To find out for sure and to more closely narrow down the problem you will need to have a compression test performed on all cylinders to determine what needs to be done next.
On the code P2509 it is referring to a charging system issue normally leading to one or both batteries being weak or a poor connection on one or more of the battery cable connections....
______________________________________
If you need additional information, don't hesitate to ask, I am happy to help as long as necessary to help solve your concern. Remember, a "Positive" Rating will not close this question. I receive no compensation for answering unless I receive an "ok service" or better... Thank you in advance for positive rating.... Remember, you can post a reply here whenever you want, even after rating my answer!
Thank you!
Robert
Customer: replied 1 year ago.
No smoke what's so so ever, and no blow by
Expert:  Robert R replied 1 year ago.
Thats a good sign that the engine is ok.
As for the smoke and rough running, either you have an additional injector that has failed or the one that was replaced was the wrong one...
There are 2 different injectors available for the 5.9 engine Standard output and High Output. If the wrong one was installed it can cause rough running and excessive smoke..
Many times when an injector fails in a 5.9 they can keep failing one after the other especially if there has been contamination present at one time or another (water, dirt, etc). When the number 4 was replaced was there any rust present on the connector tube? If so, It means that there is rust on the rest of them and you will need to replace all injectors to solve this issue.
______________________________________
If you need additional information, don't hesitate to ask, I am happy to help as long as necessary to help solve your concern. Remember, a "Positive" Rating will not close this question, You can post a reply here whenever you want, even after rating my answer! .
Thank you!
Robert