How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert R Your Own Question
Robert R
Robert R, ASE Certified Master
Category: Dodge
Satisfied Customers: 3890
Experience:  Dodge Master Certified, Dodge Sprinter Certified
Type Your Dodge Question Here...
Robert R is online now
A new question is answered every 9 seconds

ram 2500: Codes p1451 and p242d cleared and tried to perform

Resolved Question:

Codes p1451 and p242d cleared and tried to perform de soot with star scan and it aborted and set all three egt sensor codes 242d,0546, and 2033. all were reading 300 degrees at that time. Check for software update and it is 62350430AZ which is current if my info is correct. No history on truck dealer just bought at auction.
Submitted: 3 years ago.
Category: Dodge
Expert:  Robert R replied 3 years ago.
Hello, welcome and thanks for asking your question. My name isXXXXX am a Certified Auto Technician with 26+ years experience. I will do my best to assist you. please keep in mind that I may need to ask questions of you before I can answer. When you reply please feel free to add as much detailed information as possible pertaining to your concern.

Was that second code a 242d or a 242F? I see the 242F more commonly set with the P1451..

How many miles are on the vehicle?

I am researching this concern for you and will get back with you as soon as possible, Thanks for your patience while I gather the information needed for your answer. Your understanding is greatly appreciated.



PS - I also need to let you know that my responses may be delayed because I may be helping another customer, or I may be temporarily offline. Your understanding is greatly appreciated. Thank you...
Customer: replied 3 years ago.
242D. 125,000 miles.
Expert:  Robert R replied 3 years ago.
Hello Billie,

Sorry for the delay...

I have had a chance to research this for you and need a bit more info from you....

Have you already inspected the exhaust system and verified that all 3 exhaust temperature sensors and the Cat Converters and the DPF is actually present and connected? If the exhaust system is intact and still Factory I suspect a wiring issue on the exhaust temperature sensors.. I recommend inspecting the wiring as it is down low on the transmission crossmember and can sometimes get damaged by the vehicle going over road debris...

Let me know the above info and we can continue from there...

Thank you,

Customer: replied 3 years ago.
It is all there and doesn't look like it has been touched. I did unplug a couple connectors and all looks good. Will look by cross member in the am but truck is really clean underneath. Did notice when engine temp was cool and at idle all the sensors were reading 0 degrees and 5 volts. Haven't seen many of these systems yet so I'm not sure if that's normal or not. I would think they would warm up as the exhaust does?
Expert:  Robert R replied 3 years ago.
If they were reading 5 volts that usually means there is an open circuit.. I would normally replace the Temp sensor, but since it is setting the codes for all 3 I suspect a wiring issue, check that complete harness all the way up to the transmission bell housing, the temp sensors are part of the transmission harness....

When you turn on the key, the temp sensors should be reading ambient temperature. And after starting the engine they should climb from there. after you figure out the problem there, the Desoot Process should complete successfully... Hopefully you can run the "Stationary Desoot" process with the StarScan...

If you can't find anything obvious, let me know, I can post the diagnostic procedure to help you trace the wiring and do the continuity tests... Let me know if you need them and I will post them for you....

After you get a chance to look underneath, let me know what you find so we can continue...

Thank you,

Customer: replied 3 years ago.
Found broken sensor ground wire. Repaired and performed desoot all good. Thanks.
Expert:  Robert R replied 3 years ago.
Hello Billie,

I'm glad you were able to get this figured out, I hope I was able to help...

Remember, if you need help in the future, you can always request me through my profile at Begin your question with “Robert R" so I will be able to easily find it...

Thank you and thanks for using JustAnswer!

Robert R and other Dodge Specialists are ready to help you

Related Dodge Questions