How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim Mohr Your Own Question
Tim Mohr
Category: Dodge
Satisfied Customers: 14987
Type Your Dodge Question Here...
Tim Mohr is online now
A new question is answered every 9 seconds

3500 Pickup: 5.9 truck..CAN connection of the ecm mounted

Resolved Question:

I have a 1999 Dodge 3500 Pickup with a 5.9 Cummins Engine. I have installed a TS Performance engine tuner into my truck. One of the connections of this tuner gets plugged into the CAN connection of the ECM mounted on the Cummins engine. Our problem is the performance tuner is not working. We have tried a second performance tuner and it is not working. The engine performs fine & I have never seen a check engine light & it has not set any codes. We are suspicioning that the performance tuner is unable to interface with the CAN connection of the ECM. I have tested the 2 wires between the CAN connector & the ECM harness connector. They tested good. I need to know how to test the ECM CAN connection to see if the ECM is possibly defective in this area. Is there possibly a voltage test or resistance test that can be done at the CAN connector? Also, I would like to verify what colors the CAN connection wires are suppose to be. Mine are yellow & light green. The reason I ask this, is because the TS Performance company sent a harness with a triangle shaped connector that plugged right into a triangle shaped connector I found on my truck. But they also sent an adapter along because some trucks have a different shaped CAN connector. There is another flat shaped 2 wire connector right next to the triangle shaped connector I plugged into. This connector has a red wire with a white tracer and a black wire with a white tracer. This connection does not match the adapter they sent along so I assume that I am plugged into the correct location. But now I wonder, if the Performance Company could have me plugged into the wrong location.
Submitted: 5 years ago.
Category: Dodge
Expert:  Tim Mohr replied 5 years ago.
Hi, my name is XXXXX XXXXX the vehicle runs good and there are no codes, then the can bus system is good, if it were bad, it would set a code and you also would not be able to communicate with the computer, I have installed hundreds of tuners, but havent heard of the TS tuner, where did you get it?
Customer: replied 5 years ago.




I don't quite understand or agree with your answer. Would it be possilble for me to

call you? I am not good in typing, I am very slow. I also have a few more questions.







Expert:  Tim Mohr replied 5 years ago.
we are not allowed to give out our phone numbers or email addresses, this is the policy of Just Answers, not mine, we will have to communicate through here, the Can bus system is the path that the computers and the dash travel to communicate, if you lose the bus, you would definetely set a code and the dash usually goes out, where did you get this tuner, all the tunners we install in the 24 valves are connected at the injection pump not the can bus, can you give a little more info on this tuner?
Customer: replied 5 years ago.

Tim this tuner is built by TS Performance Products. I did tell you a small lie. Before I

had this tuner I had a Hypertech Programmer in this truck for the last 5 years. I have

taken this programmer out and reinstalled it a few times over the last 5 years. But now when I install this programmer and try to charge it, I find two trouble codes. They are

P0602 and P1693. I cleared the codes and drove the truck a few miles. I took the truck

to the Dodge Dealer to have them check the ECM. It seems not to set the codes without the Hypertech Programmer installed. The Dodge Dealer showed me on his

computer where it says some programmers will cause the ECM to set codes, but the ECM has never set these codes with the Hypertech Programmer in it until now. This makes me feel something might be going wrong with the ECM. The Hypertech Programmer is installed through the connection under the dash and that is where you

hook up test boxes. The CAN connector is hooked directly to the ECM under the hood.

Are you telling me these two connections are related or hooked together?

Expert:  Tim Mohr replied 5 years ago.
we have had problems with the Hypertechs, not in performance, but in uninstalling the program, i had a customer that had the hypertech and wanted the Edge tuner, and we could not get the programming out of the computer for the hyper tech, and could not install the Edge until we replaced the ECM, this has happened twice sofar with different trucks with the hypertechs, it is possible the original programming of the hypertech is not allowing the TS tuner to work, but if there was a problem with the can bus, you would definetely know it by codes or hard faults,Tim
Tim Mohr and other Dodge Specialists are ready to help you

Related Dodge Questions