How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Vladgmru Your Own Question

Vladgmru
Vladgmru, Automotive Electrician
Category: Dodge
Satisfied Customers: 2519
Experience:  I've been working with American made cars since 1992.
12883947
Type Your Dodge Question Here...
Vladgmru is online now
A new question is answered every 9 seconds

2003 dodge ram 1500 4.7 truck just started running really rough

Customer Question

2003 dodge ram 1500 4.7 truck just started running really rough have changed plugs, coils, tps cleaned IAC still runs rough
Submitted: 4 years ago.
Category: Dodge
Expert:  brownjeff replied 4 years ago.
Hello and Welcome to JustAnswer,

My name is XXXXX XXXXX I am here to try and assist your with your question. Does the check engine light come on and if so any codes?
Customer: replied 4 years ago.
yes code 121
Expert:  brownjeff replied 4 years ago.
This is a code for the tps which I'm sure you know since the tps was replaced. Did you also check the wiring to the tps? What voltage are you getting to it?
Customer: replied 4 years ago.

4.9 volts

 

Expert:  brownjeff replied 4 years ago.
When moving the throttle with the key on and engine not running what voltage readings are you getting out of the sensor? Does it change when opening the throttle?
Customer: replied 4 years ago.
had volt meter on wrong setting i got 10.8 volts and no change when moving throttle
Expert:  brownjeff replied 4 years ago.
You checked the other wires too? Not just the input wire correct?
Customer: replied 4 years ago.
what should i have for a reading
Expert:  brownjeff replied 4 years ago.
First should only have 5 volts in then when moving the throttle should range from .26 to 4.49 volts leaving the sensor. So we have too much to start with but also want to see if it changes going out of the sensor
Customer: replied 4 years ago.

ok had it on wrong setting i got 5 moving the throttle it changes up to 7.3 with wide open

 

Expert:  brownjeff replied 4 years ago.
OK.....still not making sense.....

Remove the connector and with the key on tell me the voltage readings on each wire.
Customer: replied 4 years ago.

ground 0

center 0.5 move throttle 3.6

front 5 no change with throttle

 

Expert:  brownjeff replied 4 years ago.
That is with the connector disconnected?
Customer: replied 4 years ago.
with it disconnected and connected
Expert:  brownjeff replied 4 years ago.
Try to loosen the tps bolts and see if you can rotate the sensor any to get the 3.6 reading closer to 4.49 when moving the throttle
Customer: replied 4 years ago.
ok give me 5 min
Expert:  brownjeff replied 4 years ago.
ok
Customer: replied 4 years ago.
if i disconnect the bolts i can turn it to get 4.5 but i can't get the bolts to go back
Expert:  brownjeff replied 4 years ago.
Remove the sensor then and install it like this......

The throttle shaft end of throttle body slides into a socket in TPS. The TPS must be installed so that it can be rotated a few degrees. If sensor will not rotate, install sensor with throttle shaft on other side of socket tangs. The TPS will be under slight tension when rotated.

Attachments are only available to registered users.

Register Here
Customer: replied 4 years ago.
correct i did that with the bolts installed the most i get is 3.8
Expert:  brownjeff replied 4 years ago.
If the throttle is not bent, damaged, or altered in any way then would get another sensor and see if you can adjust it correctly.
Customer: replied 4 years ago.
have another one on hand i'll give it a try hold on
Expert:  brownjeff replied 4 years ago.
will do
Customer: replied 4 years ago.
tried both units the most i can get with them istalled is 3.8
Expert:  brownjeff replied 4 years ago.
Does it run any better at the 3.8 setting?
Customer: replied 4 years ago.
no
Expert:  brownjeff replied 4 years ago.
I also do not understand how/why there is voltage to the sensor output wire with the sensor disconnected? Just not adding up?
Customer: replied 4 years ago.
possible short in the system
Expert:  brownjeff replied 4 years ago.
Yes very possible as the signal wire should not have voltage if not connected to the sensor
Customer: replied 4 years ago.

with harness disconnected i got ground at o

center wire at 4.9 when attatched to the tps it drops to .7

third wire stays atXXXXX/p>

Expert:  brownjeff replied 4 years ago.
I will see if another person here on the site has seen this before as it sounds like a powertrain control module problem to me but not sure.

I will send your question to them and see if they can help

Edited by brownjeff on 10/25/2010 at 8:27 PM EST
Customer: replied 4 years ago.
thank you i will return in about 30 minutes
Customer: replied 4 years ago.

sorry about that had to pick up the wife from work so where do we stand as of yet

 

Customer: replied 4 years ago.
hello is anybody there
Expert:  Vladgmru replied 4 years ago.
Hi,
I am another expert and my name is Vladimir.
Turn the key Off, disconnect the negative battery terminal and then try to disconnect the airbag clockspring that is located under the steering wheel within the steering column ( you may need to remove the steering column upper and lower shrouds to get to the clockspring connectors).
Once you disconnect the airbag clocksping, connect the battery back and see if your trouble code gets away when you operate the engine.
If there is not any problem with the clockspring disconnected, then just replace it with a new genuine Mopar clockspring. ( Remember to disconnect the battery when you work with the airbag components).
Customer: replied 4 years ago.
wrong guy for this answer my issue is rough running engine but hey thanks for trying
Expert:  Vladgmru replied 4 years ago.
How do you know I am wrong if you never tried that?
Your airbag clockspring could be internally shorted to power and that causes your engine controller to see wrong TPS voltage.
I am not going to argue, if you do not like my answer, I could opt out and open your question second time for a third expert.
Thanks,
Vlad.
Customer: replied 4 years ago.
question could this cause the problem to start within 5 minutes after turning the engine off then restarting it i mean no bumpy roads or anything just drove to a place ran fine turned it off came out 5 minutes later started it up and wham really rough so pardon me about the clockspring did'nt know
Expert:  Vladgmru replied 4 years ago.
If it is an intermittent issue, the answer is yes it could cause.
My answer is solely based on information you provide me.
If you get TPS trouble code and can't clear it, then you should find and eleminate the reason and then move further.
I would also check for fuel pressure, just to be sure your fuel pump supplies enough fuel.
(49 PSI)

JustAnswer in the News:

 
 
 
Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.
 
 
 

What Customers are Saying:

 
 
 
  • I AM VERY GLAD THAT I TOOK A CHANCE ON YOUR PROBLEM SOLVING SKILLS. I WAS SUCCESSFUL IN REPLACING THE FUEL PUMP. MY TRUCK RUNS LIKE A CLOCK. IT RUNS LIKE THE DAY I BOUGHT IT. NO LUNGING FORWARD, THE TURBO REACTS THE SECOND I STOMP ON THE GAS, AND IT HAS A LOT MORE POWER AND EVEN SOUNDS BETTER TO ME. IT SAVED ABOUT $500.00 BY DOING THE WORK MYSELF. I GIVE YOU ALL THE CREDIT FOR YOUR DIAGNOSING THE PROBLEM, JUST FROM THE SYMPTONS I GAVE YOU OVER THE e MAIL. I WILL USE YOUR WEB SITE AGAIN AND REFER MY FRIENDS. THANKS SO MUCH FOR THE HELP. TOM WHITTAKER USA
< Last | Next >
  • I AM VERY GLAD THAT I TOOK A CHANCE ON YOUR PROBLEM SOLVING SKILLS. I WAS SUCCESSFUL IN REPLACING THE FUEL PUMP. MY TRUCK RUNS LIKE A CLOCK. IT RUNS LIKE THE DAY I BOUGHT IT. NO LUNGING FORWARD, THE TURBO REACTS THE SECOND I STOMP ON THE GAS, AND IT HAS A LOT MORE POWER AND EVEN SOUNDS BETTER TO ME. IT SAVED ABOUT $500.00 BY DOING THE WORK MYSELF. I GIVE YOU ALL THE CREDIT FOR YOUR DIAGNOSING THE PROBLEM, JUST FROM THE SYMPTONS I GAVE YOU OVER THE e MAIL. I WILL USE YOUR WEB SITE AGAIN AND REFER MY FRIENDS. THANKS SO MUCH FOR THE HELP. TOM WHITTAKER USA
  • Just a quick line to tell you how pleased I am to have my brakes working properly after all this time. Your answer was what I needed. I would certainly recommend you highly. God bless! Rev. Jerry Baysinger Holts Summit, Mo
  • I recently asked a question about my 2005 dodge ram, and I just wanted to let my Expert know that he hit the nail squarely on the head with his answer. I wanted to thank him again. Greg Pittsburgh, PA
  • Just a quick line to tell you how pleased I am to have my brakes working properly after all this time. Your answer was what I needed. I would certainly recommend you highly. God bless! Jerry Holts Summit, MO
  • I was skeptical at first but thought I'd give it a try. I was pleasantly surprised. Your site actually is a quality service that I would recommend to others in a heartbeat. Stan Sayre, PA
  • Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help. Mary C. Freshfield, Liverpool, UK
  • This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!! Alex Los Angeles, CA
 
 
 

Meet The Experts:

 
 
 
  • Jerry

    Master Mechanic

    Satisfied Customers:

    1227
    ASE Master tech, 30 years exp. troubleshooter, driveability tech
< Last | Next >
  • http://ww2.justanswer.com/uploads/SU/supermechanic/2013-8-23_03546_500.64x64.jpg Jerry's Avatar

    Jerry

    Master Mechanic

    Satisfied Customers:

    1227
    ASE Master tech, 30 years exp. troubleshooter, driveability tech
  • http://ww2.justanswer.com/uploads/MO/MoparCertified/2012-6-7_4142_mechanic.64x64.jpg Mopar Certified's Avatar

    Mopar Certified

    Dodge Technician

    Satisfied Customers:

    5813
    24 Year Chrysler/Dodge Certified Specialist
  • http://ww2.justanswer.com/uploads/jeep10000/2008-9-18_222938_192601.jpg Chris's Avatar

    Chris

    Shop Foreman

    Satisfied Customers:

    4041
    ASE and Chrysler Certified Master Tech
  • http://ww2.justanswer.com/uploads/ke4ich/2009-08-12_212931_DSC02211.JPG moparfl's Avatar

    moparfl

    ASE Certified Technician

    Satisfied Customers:

    3285
    ASE Master Tech Gold level Chrysler Status 30 years dealership exp
  • http://ww2.justanswer.com/uploads/DO/dodgerench/2012-8-1_1142_IMG3173.64x64.JPG Dodgerench's Avatar

    Dodgerench

    ASE Certified Technician

    Satisfied Customers:

    2480
    30+ years Dodge/Chrysler exp., ASE Master with L1 certification. Driveability/ combustion specialist
  • http://ww2.justanswer.com/uploads/RO/rodcuda/2011-7-25_224114_Donhoff1.64x64.JPG Neal's Avatar

    Neal

    Dodge Mechanic

    Satisfied Customers:

    1870
    30 years experience in Dodge Chrysler and Plymouth
  • http://ww2.justanswer.com/uploads/tsmodie/2009-6-10_144056_tim.jpg Tim Mohr's Avatar

    Tim Mohr

    ASE MASTER TECH

    Satisfied Customers:

    1664
    30 YRS EXPERIENCE, FOREIGN AND DOMESTIC, GAS AND DEISEL
 
 
 
Chat Now With A Dodge Mechanic
Vladgmru
Vladgmru
Automotive Electrician
373 Satisfied Customers
I've been working with American made cars since 1992.