How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask kennyb28 Your Own Question
kennyb28
kennyb28, Service Manager
Category: Dodge
Satisfied Customers: 355
Experience:  Many years of hands on experience
13529731
Type Your Dodge Question Here...
kennyb28 is online now
A new question is answered every 9 seconds

1996 dodge ram 1500: firing order..spark plug wires, cap and rotor

Customer Question

Hi! I'm trying to repair a 1996 dodge ram 1500 with the 5.2L engine . It run like if the firing order was not o.k., but it is. We have changed the cranksensor, spark plug wires, cap and rotor with no succes. And now it start but stall immedietaly. No DTC or pending DTC.
Submitted: 8 years ago.
Category: Dodge
Expert:  kennyb28 replied 8 years ago.


Hello, you mention that it does start. Do you have to jump start it to get it started, and it runs rough after that? Trying to figure out whats happening here so I can help get you running.

Thanks

Kenny

Customer: replied 8 years ago.
Client came here with engine running very very rough. Under 2000 rpm it would just stall if he did'nt help it with the gas pedal.The spark plug, wires cap and rotor where changed at another auto center. firing order is o.k.. We changed the crank sensor and now it's worse. The engine crank good but it won't start or run extremely rough and backfiring. When we crank it looks like a engine with the timing belt loose. The old crank sensor looks like it was touching the ring gear.
We checked the holes on the ring gear where the cranck sensor is reading and its o.k.

Thank you for your help.
Sorry for my poor english, but we speak french up here.
Eric
Québec city, Canada.
Expert:  kennyb28 replied 8 years ago.
Have you checked that the battery is good and has good connection? If it were anything to do with timing it would set a fault code. If this is the case, and it just needs help with the battery and connection, please hit accept. If not please reply and i'll continue helping with diagnosis.
Expert:  kennyb28 replied 8 years ago.
If this is the case, and it just needs help with the battery and connection, please hit accept. If not please reply and i'll continue helping with diagnosis.
Customer: replied 8 years ago.
the engine cranks good. Battery and strter are o.k.!!! no code or pending code
Expert:  kennyb28 replied 8 years ago.
since you have already replaced the plugs, cap and rotor, and ensured that wires are all hooked up properly, and replaced the crank sensor, have you tried resetting to top dead center, and clearing all the memory. (battery disconnect)
kennyb28 and 4 other Dodge Specialists are ready to help you
Customer: replied 8 years ago.
resetting top dead center and clearing all memory: done.
Expert:  kennyb28 replied 8 years ago.

Does it still not run? Has condition changed any?

Customer: replied 8 years ago.

We found the problem. The ring gear was not oem. The crank sensor needed to be modified !!!! It now run great.

 

Bye!

Expert:  kennyb28 replied 8 years ago.

Wow, thats random.