How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mndave0002 Your Own Question
mndave0002, engineer
Category: Dodge
Satisfied Customers: 528
Experience:  Design engineer and toolmaker mechanic previous ASE mech and ICARE body man
Type Your Dodge Question Here...
mndave0002 is online now
A new question is answered every 9 seconds

Runs rough at 45mph to 55mph wants stall at idle

Customer Question

runs rough at 45mph to 55mph wants stall at idle
Submitted: 8 years ago.
Category: Dodge
Expert:  mndave0002 replied 8 years ago.

Hi, welcome to

It would help to know year, model, motor, and mileage of vehicle. Are you or were you getting any warning lights? If so return here and I can tell you how to retrieve them plus what they are for. Possibly even if they are not still lit.

looks like they are for 2001

320Crankshaft position sensor reference signal cannot be found while the engine is cranking.

for after 2004

P0320 Ignition/Distributor Engine Speed Input Circuit Malfunction

hope this helps.______________

Customer: replied 8 years ago.
Reply to mndave0002's Post: its a 2001 dodge dakota quad cab 4.7 liter 184,000 mile and check engine light came on
Expert:  mndave0002 replied 8 years ago.

ok look at the crank possition sensor make sure the wiers are good. And it has not been bumped or moved. When you get codes like thsi it does not meen that the part is bad only it is not getting or sending a good signal. This one says not a signal at all. It shoudl get power when ever the engine is moving. So look it over real well. Are you mechanical if so I can post some instructions to check it and replace it too.

:Let me know

hope this helps

If this helps click accept and thanks

Expert:  mndave0002 replied 8 years ago.
Was your problem crank position sensor? If nto let me know and we can look at other problems

Related Dodge Questions